summaryrefslogtreecommitdiffstats
path: root/job-cfg
diff options
context:
space:
mode:
Diffstat (limited to 'job-cfg')
-rw-r--r--job-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/job-cfg/Makefile b/job-cfg/Makefile
new file mode 100644
index 00000000..bf324c95
--- /dev/null
+++ b/job-cfg/Makefile
@@ -0,0 +1,20 @@
+
+
+PYYAMLS := $(basename $(wildcard *.yaml.py))
+
+YAMLS := $(wildcard *.yaml) $(PYYAMLS)
+
+XMLS := $(patsubst %.yaml,%.xml,$(YAMLS))
+
+OUTPUTS := $(PYYAMLS) $(XMLS)
+
+all: $(OUTPUTS)
+
+%.yaml: %.yaml.py
+ ./$< > $@
+
+%.xml: %.yaml
+ jenkins-jobs test $< > $@
+
+clean:
+ rm $(sort $(OUTPUTS))