summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/chroot-run.sh5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index a0f0dd43..436d57ea 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -85,6 +85,11 @@ run() {
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
cd /testrun
+if [ -f debian/control ] ; then
+ # install build-depends
+ apt-get -y install build-essential devscripts
+ mk-build-deps -ir
+fi
$@
EOF
chmod +x $CHROOT_TARGET/tmp/chroot-testrun