summaryrefslogtreecommitdiffstats
path: root/bin/chroot-run.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/chroot-run.sh')
-rwxr-xr-xbin/chroot-run.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 858f46e0..813ef564 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -141,7 +141,8 @@ echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
apt-get install build-essential devscripts git
if [ "$1" = "gbp" ] ; then
apt-get install git-buildpackage
- git checkout debian
+ # either there is a debian branch or not
+ git checkout debian || echo "No debian branch exists, assuming packaging is in master branch."
fi
if [ -f debian/control ] ; then
cat debian/control