summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--TODO1
-rwxr-xr-xbin/reproducible_common.sh1
-rwxr-xr-xbin/reproducible_create_meta_pkg_sets.sh11
3 files changed, 12 insertions, 1 deletions
diff --git a/TODO b/TODO
index 8a9c8d64..b5a7c620 100644
--- a/TODO
+++ b/TODO
@@ -202,7 +202,6 @@ properties:
* pkg sets related:
** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential)
** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control
-** add lua package set (all packages build-depending on dh-lua and starting with lua*)
* missing tests:
** variation in kernel
diff --git a/bin/reproducible_common.sh b/bin/reproducible_common.sh
index 5a7f51ec..d904191b 100755
--- a/bin/reproducible_common.sh
+++ b/bin/reproducible_common.sh
@@ -91,6 +91,7 @@ META_PKGSET[25]="maint_pkg-javascript-devel"
META_PKGSET[26]="maint_debian-boot"
META_PKGSET[27]="maint_debian-ocaml"
META_PKGSET[28]="maint_debian-x"
+META_PKGSET[29]="maint_lua"
schedule_packages() {
LC_USER="$REQUESTER" \
diff --git a/bin/reproducible_create_meta_pkg_sets.sh b/bin/reproducible_create_meta_pkg_sets.sh
index 1338bdf9..4fbd9ad5 100755
--- a/bin/reproducible_create_meta_pkg_sets.sh
+++ b/bin/reproducible_create_meta_pkg_sets.sh
@@ -368,6 +368,17 @@ update_pkg_sets() {
update_if_similar ${META_PKGSET[28]}.pkgset
fi
+ # lua packages
+ if [ ! -z $(find $TPATH -maxdepth 1 -mtime +0 -name ${META_PKGSET[29]}.pkgset) ] || [ ! -f $TPATH/${META_PKGSET[29]}.pkgset ] ; then
+ # get a bunch of binary packages names and convert them to source package names
+ grep-dctrl -sPackage -n -FPackage -e ^lua.* $PACKAGES > $TMPFILE
+ packages_list_to_deb822
+ convert_from_deb822_into_source_packages_only
+ # add some more source package names
+ grep-dctrl -sPackage -n -FBuild-Depends dh-lua $SOURCES | sed "s#([^()]*)##g ; s#\[[^][]*\]##g ; s#,##g" | sort -u >> $TMPFILE
+ update_if_similar ${META_PKGSET[29]}.pkgset
+ fi
+
}
TMPFILE=$(mktemp --tmpdir=$TEMPDIR pkg-sets-XXXXXXXXX)