summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/chroot-run.sh13
-rwxr-xr-xjob-cfg/rebootstrap.yaml.py2
2 files changed, 12 insertions, 3 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 05df628b..577fc62c 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -11,7 +11,7 @@ common_init "$@"
# $2 $3 ... = command to run inside a clean chroot running the distro in $1
if [ $# -lt 2 ]; then
- echo "usage: $0 DISTRO [backports] CMD [ARG1 ARG2 ...]"
+ echo "usage: $0 DISTRO [backports|minimal] CMD [ARG1 ARG2 ...]"
exit 1
fi
@@ -24,6 +24,11 @@ if [ "$1" == "backports" ] ; then
shift
fi
+if [ "$1" == "minimal" ] ; then
+ MINIMAL=yes
+ shift
+fi
+
if [ ! -d "$CHROOT_BASE" ]; then
echo "Directory $CHROOT_BASE does not exist, aborting."
exit 1
@@ -79,6 +84,9 @@ run() {
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
cd /tmp/testrun
+EOF
+ if [ "$MINIMAL" != "yes" ]; then
+ cat >> $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
apt-get install build-essential devscripts git
if [ -f debian/control ] ; then
@@ -86,8 +94,9 @@ if [ -f debian/control ] ; then
# install build-depends
mk-build-deps -ir
fi
-$@
EOF
+ fi
+ echo "$*" >> $CHROOT_TARGET/tmp/chroot-testrun
chmod +x $CHROOT_TARGET/tmp/chroot-testrun
sudo chroot $CHROOT_TARGET /tmp/chroot-testrun
diff --git a/job-cfg/rebootstrap.yaml.py b/job-cfg/rebootstrap.yaml.py
index 201e3743..de70f5d9 100755
--- a/job-cfg/rebootstrap.yaml.py
+++ b/job-cfg/rebootstrap.yaml.py
@@ -61,7 +61,7 @@ print("""
branches:
- '{my_branchname}'
builders:
- - shell: '/srv/jenkins/bin/chroot-run.sh sid ./bootstrap.sh HOST_ARCH={my_arch} {my_params}'
+ - shell: '/srv/jenkins/bin/chroot-run.sh sid minimal ./bootstrap.sh HOST_ARCH={my_arch} {my_params}'
publishers:
- email:
recipients: 'jenkins+debian-bootstrap helmutg@debian.org'