summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/chroot-installation.sh6
-rwxr-xr-xbin/chroot-run.sh3
l---------etc/munin/plugins/diskstats1
l---------etc/munin/plugins/iostat1
l---------etc/munin/plugins/iostat_ios1
-rw-r--r--job-cfg/lintian-tests.yaml6
-rwxr-xr-xjob-cfg/rebootstrap.yaml.py8
-rwxr-xr-xupdate_jdn.sh5
8 files changed, 21 insertions, 10 deletions
diff --git a/bin/chroot-installation.sh b/bin/chroot-installation.sh
index b53d5177..28ac3dd3 100755
--- a/bin/chroot-installation.sh
+++ b/bin/chroot-installation.sh
@@ -58,6 +58,7 @@ prepare_install_packages() {
cat >> $CTMPFILE <<-EOF
$SCRIPT_HEADER
apt-get -y install $@
+apt-get clean
EOF
}
@@ -65,9 +66,11 @@ prepare_install_build_depends() {
cat >> $CTMPFILE <<-EOF
$SCRIPT_HEADER
apt-get -y install build-essential
+apt-get clean
EOF
for PACKAGE in $@ ; do
echo apt-get -y build-dep $PACKAGE >> $CTMPFILE
+ echo apt-get clean >> $CTMPFILE
done
}
@@ -77,8 +80,11 @@ echo "deb $MIRROR $1 main contrib non-free" >> /etc/apt/sources.list
$SCRIPT_HEADER
apt-get update
apt-get -y upgrade
+apt-get clean
apt-get -yf dist-upgrade
+apt-get clean
apt-get -yf dist-upgrade
+apt-get clean
apt-get -y autoremove
EOF
}
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index a1388c6f..18f14a2a 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -26,6 +26,7 @@ fi
if [ "$1" == "minimal" ] ; then
MINIMAL=yes
+ BOOTSTRAP_OPTIONS=--variant=minbase
shift
fi
@@ -47,7 +48,7 @@ bootstrap() {
echo force-unsafe-io > "$CHROOT_TARGET/etc/dpkg/dpkg.cfg.d/02dpkg-unsafe-io"
echo "Bootstraping $DISTRO into $CHROOT_TARGET now."
- if ! sudo debootstrap $DISTRO $CHROOT_TARGET $MIRROR; then
+ if ! sudo debootstrap $BOOTSTRAP_OPTIONS $DISTRO $CHROOT_TARGET $MIRROR; then
SLEEPTIME=1800
echo "debootstrap failed, slowing down, sleeping $SLEEPTIME now..."
sleep $SLEEPTIME
diff --git a/etc/munin/plugins/diskstats b/etc/munin/plugins/diskstats
new file mode 120000
index 00000000..d44002b7
--- /dev/null
+++ b/etc/munin/plugins/diskstats
@@ -0,0 +1 @@
+/usr/share/munin/plugins/diskstats \ No newline at end of file
diff --git a/etc/munin/plugins/iostat b/etc/munin/plugins/iostat
new file mode 120000
index 00000000..b3b1256e
--- /dev/null
+++ b/etc/munin/plugins/iostat
@@ -0,0 +1 @@
+/usr/share/munin/plugins/iostat \ No newline at end of file
diff --git a/etc/munin/plugins/iostat_ios b/etc/munin/plugins/iostat_ios
new file mode 120000
index 00000000..622beb24
--- /dev/null
+++ b/etc/munin/plugins/iostat_ios
@@ -0,0 +1 @@
+/usr/share/munin/plugins/iostat_ios \ No newline at end of file
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index 64067927..d1119e5f 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -60,16 +60,16 @@
jobs:
- '{name}_sid':
my_distro: 'sid'
- my_shell: 'debian/rules runtests'
+ my_shell: 'timeout 6h debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on sid.'
my_trigger: 'lintian-tests_jessie'
- '{name}_jessie':
my_distro: 'jessie'
- my_shell: 'debian/rules runtests'
+ my_shell: 'timeout 6h debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on jessie.'
my_trigger: 'lintian-tests_wheezy'
- '{name}_wheezy':
my_distro: 'wheezy backports'
- my_shell: 'debian/rules runtests'
+ my_shell: 'timeout 6h debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on wheezy (+backports).'
diff --git a/job-cfg/rebootstrap.yaml.py b/job-cfg/rebootstrap.yaml.py
index 321882db..0e048316 100755
--- a/job-cfg/rebootstrap.yaml.py
+++ b/job-cfg/rebootstrap.yaml.py
@@ -4,17 +4,17 @@ architectures = """
i386
hppa
mips mips64el mipsel
- powerpc powerpcspe ppc64 ppc64el
- s390 s390x
+ powerpc powerpcspe ppc64
+ s390x
sparc sparc64
x32
""".split()
mono_architectures = """
- arm armel armhf arm64
+ armel armhf arm64
alpha
- ia64
m68k
+ ppc64el
or1k
sh4
""".split()
diff --git a/update_jdn.sh b/update_jdn.sh
index 72cd2dc4..4efe8bac 100755
--- a/update_jdn.sh
+++ b/update_jdn.sh
@@ -25,7 +25,7 @@ done
# install packages we need
# (more or less grouped into more-then-nice-to-have, needed-while-things-are-new, needed)
#
-sudo apt-get install vim screen less etckeeper moreutils curl mtr-tiny dstat devscripts bash-completion shorewall shorewall6 cron-apt apt-listchanges munin calamaris visitors procmail libjson-rpc-perl libfile-touch-perl zutils ip2host \
+sudo apt-get install vim screen less etckeeper moreutils curl mtr-tiny dstat devscripts bash-completion shorewall shorewall6 cron-apt apt-listchanges munin munin-plugins-extra calamaris visitors procmail libjson-rpc-perl libfile-touch-perl zutils ip2host \
build-essential python-setuptools \
debootstrap sudo figlet graphviz apache2 python-yaml python-pip mr subversion subversion-tools vnstat webcheck poxml vncsnapshot imagemagick ffmpeg2theora python-twisted python-imaging gocr guestmount schroot
sudo apt-get install -t wheezy-backports qemu
@@ -54,9 +54,10 @@ fi
sudo chown root.root /etc/sudoers.d/jenkins ; sudo chmod 700 /etc/sudoers.d/jenkins
sudo ln -sf /etc/apache2/sites-available/jenkins.debian.net /etc/apache2/sites-enabled/000-default
sudo service apache2 reload
-cd /etc/munin/plugins ; sudo rm -f postfix_* open_inodes df_inode interrupts diskstats irqstats threads proc_pri vmstat if_err_eth0 fw_forwarded_local fw_packets forks open_files users 2>/dev/null
+cd /etc/munin/plugins ; sudo rm -f postfix_* open_inodes df_inode interrupts irqstats threads proc_pri vmstat if_err_eth0 fw_forwarded_local fw_packets forks open_files users 2>/dev/null
[ -L apache_accesses ] || for i in apache_accesses apache_volume ; do ln -s /usr/share/munin/plugins/$i $i ; done
explain "Packages configured."
+sudo service munin-node force-reload
#
# install the heart of jenkins.debian.net