summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--TODO11
-rwxr-xr-xjob-cfg/chroot-installation.yaml.py14
-rw-r--r--job-cfg/debsums-tests.yaml4
-rw-r--r--job-cfg/dpkg.yaml34
-rw-r--r--job-cfg/dvswitch.yaml14
-rw-r--r--job-cfg/lintian-tests.yaml16
-rw-r--r--job-cfg/piuparts.yaml37
-rw-r--r--job-cfg/udd.yaml9
8 files changed, 121 insertions, 18 deletions
diff --git a/TODO b/TODO
index 2466bfed..0a13bc2c 100644
--- a/TODO
+++ b/TODO
@@ -33,6 +33,15 @@ See link:https://jenkins.debian.net/userContent/about.html["about jenkins.debian
** '/srv/jenkins.debian.net-scm-sync.git'
** '/etc/.git' and '/etc'
+=== TODO for testing stretch
+
+Most jobs have been converted, a few are left to do:
+
+* add g-i tests for stretch
+** also d-edu jessie beta1 cd+usb images
+** rename current g-i d-edu jessie tests to g-i edu jessie dailies
+* add stretch live-builds
+* do lvc for stretch too
=== move this setup to jenkins.d.o
@@ -176,7 +185,7 @@ grep '(=.*).,.$' rygel_0.24.2-1.debbindiff.html | uniq -c | sort | grep -c '^\s*
** "fork" etc/schroot/default into etc/schroot/reproducible
** use one css for all, not two minimally different ones
** repo-comparison: check for binaries without source
-
+** reproducible_create_meta_pkg_sets uses schroot created by dpkg_setup_schroot_jessie job (outside of reproducible job space...)
* notes related
** hint issues of a package while hovering over it
** new page with annoted packages without categorized issues
diff --git a/job-cfg/chroot-installation.yaml.py b/job-cfg/chroot-installation.yaml.py
index 87b62531..8d4740e4 100755
--- a/job-cfg/chroot-installation.yaml.py
+++ b/job-cfg/chroot-installation.yaml.py
@@ -4,14 +4,16 @@ base_distros = """
squeeze
wheezy
jessie
+ stretch
sid
""".split()
distro_upgrades = { 'squeeze': 'wheezy',
'wheezy': 'jessie',
- 'jessie': 'sid' }
+ 'jessie': 'stretch',
+ 'stretch': 'sid' }
-oldstable = 'squeeze'
+oldoldstable = 'squeeze'
# ftp.de.debian.org runs mirror updates at 03:25, 09:25, 15:25 and 21:25 UTC and usually they run 10m...
trigger_times = { 'squeeze': '30 16 25 * *',
@@ -206,7 +208,7 @@ for base_distro in sorted(base_distros):
else:
action = 'install_'+target
# default job
- if target == 'maintenance' or base_distro != oldstable:
+ if target == 'maintenance' or base_distro != oldoldstable:
print("""- job-template:
defaults: chroot-installation
name: '{name}_%(base_distro)s_%(action)s'""" %
@@ -221,7 +223,7 @@ for base_distro in sorted(base_distros):
action=action,
second_base=distro_upgrades[base_distro]))
# upgrade job with upgrading apt+dpkg first
- if base_distro in distro_upgrades and base_distro != oldstable and target[:10] != 'education-' and action != 'maintenance':
+ if base_distro in distro_upgrades and base_distro != oldoldstable and target[:10] != 'education-' and action != 'maintenance':
print("""- job-template:
defaults: chroot-installation
name: '{name}_%(base_distro)s_%(action)s_upgrade_to_%(second_base)s_aptdpkg_first'""" %
@@ -270,7 +272,7 @@ for base_distro in sorted(base_distros):
else:
action = 'install_'+target
# default job
- if target == 'maintenance' or base_distro != oldstable:
+ if target == 'maintenance' or base_distro != oldoldstable:
print(""" - '{name}_%(base_distro)s_%(action)s':
my_shell: '%(shell)s'
my_prio: '%(prio)s'
@@ -321,7 +323,7 @@ for base_distro in sorted(base_distros):
second_base=distro_upgrades[base_distro],
description=description))
# upgrade job with upgrading apt+dpkg first
- if base_distro in distro_upgrades and base_distro != oldstable and target[:10] != 'education-' and action != 'maintenance':
+ if base_distro in distro_upgrades and base_distro != oldoldstable and target[:10] != 'education-' and action != 'maintenance':
description = 'Debootstrap '+base_distro+', then upgrade apt and dpkg to '+distro_upgrades[base_distro]+' and then everything else.'
if target == 'bootstrap':
trigger = ''
diff --git a/job-cfg/debsums-tests.yaml b/job-cfg/debsums-tests.yaml
index 2a18f50e..f49d325a 100644
--- a/job-cfg/debsums-tests.yaml
+++ b/job-cfg/debsums-tests.yaml
@@ -54,6 +54,10 @@
my_shell: 'timeout 5m prove -v'
my_description: 'Debian/Debsums testsuite running on sid.'
my_trigger: 'debsums-tests_jessie'
+ - '{name}_stretch':
+ my_distro: 'stretch'
+ my_shell: 'timeout 5m prove -v'
+ my_description: 'Debian/Debsums testsuite running on stretch.'
- '{name}_jessie':
my_distro: 'jessie'
my_shell: 'timeout 5m prove -v'
diff --git a/job-cfg/dpkg.yaml b/job-cfg/dpkg.yaml
index 153b7138..51c2f8d8 100644
--- a/job-cfg/dpkg.yaml
+++ b/job-cfg/dpkg.yaml
@@ -34,29 +34,45 @@
- job-template:
defaults: dpkg
+ name: '{name}_jessie_find_trigger_cycles'
+
+- job-template:
+ defaults: dpkg
+ name: '{name}_stretch_find_trigger_cycles'
+
+- job-template:
+ defaults: dpkg
name: '{name}_sid_find_trigger_cycles'
- job-template:
defaults: dpkg
- name: '{name}_testing_find_trigger_cycles'
+ name: '{name}_setup_schroot_jessie'
- job-template:
defaults: dpkg
- name: '{name}_setup_schroot'
+ name: '{name}_setup_schroot_stretch'
- project:
name: dpkg
jobs:
- - '{name}_testing_find_trigger_cycles':
- my_description: 'Find dpkg trigger cycles in Debian testing.'
+ - '{name}_jessie_find_trigger_cycles':
+ my_description: 'Find dpkg trigger cycles in Debian jessie.'
my_time: '0 10 * * *'
- my_shell: 'schroot --directory /tmp -c source:jenkins-dpkg-jessie /srv/jenkins/bin/find_dpkg_trigger_cycles.sh testing'
+ my_shell: 'schroot --directory /tmp -c source:jenkins-dpkg-jessie /srv/jenkins/bin/find_dpkg_trigger_cycles.sh jessie'
+ - '{name}_stretch_find_trigger_cycles':
+ my_description: 'Find dpkg trigger cycles in Debian stretch.'
+ my_time: '0 10 * * *'
+ my_shell: 'schroot --directory /tmp -c source:jenkins-dpkg-stretch /srv/jenkins/bin/find_dpkg_trigger_cycles.sh stretch'
- '{name}_sid_find_trigger_cycles':
- my_description: 'Find dpkg trigger cycles in sid.'
+ my_description: 'Find dpkg trigger cycles in Debian sid.'
my_time: '0 12 * * *'
- my_shell: 'schroot --directory /tmp -c source:jenkins-dpkg-jessie /srv/jenkins/bin/find_dpkg_trigger_cycles.sh unstable'
- - '{name}_setup_schroot':
- my_description: 'Setup schroot for running the dpkg_sid_find_trigger_cycles and reproducible_create_meta_pkg_sets jobs in a jessie environment.'
+ my_shell: 'schroot --directory /tmp -c source:jenkins-dpkg-stretch /srv/jenkins/bin/find_dpkg_trigger_cycles.sh unstable'
+ - '{name}_setup_schroot_jessie':
+ my_description: 'Setup schroot for running the dpkg_jessie_find_trigger_cycles and reproducible_create_meta_pkg_sets jobs in a jessie environment.'
my_time: '23 8 * * 1'
my_shell: '/srv/jenkins/bin/schroot-create.sh dpkg-jessie jessie python apt-file dose-extra'
+ - '{name}_setup_schroot_stretch':
+ my_description: 'Setup schroot for running the dpkg_sid_find_trigger_cycles and dpkg_stretch_find_trigger_cycles jobs in a stretch environment.'
+ my_time: '23 8 * * 1'
+ my_shell: '/srv/jenkins/bin/schroot-create.sh dpkg-stretch stretch python apt-file dose-extra'
diff --git a/job-cfg/dvswitch.yaml b/job-cfg/dvswitch.yaml
index 6be71273..70961a30 100644
--- a/job-cfg/dvswitch.yaml
+++ b/job-cfg/dvswitch.yaml
@@ -39,6 +39,15 @@
- job-template:
defaults: dvswitch
+ name: '{name}_stretch'
+ publishers:
+ - email:
+ recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org dvswitch-maint@debian.org'
+ - trigger:
+ project: '{my_trigger}'
+
+- job-template:
+ defaults: dvswitch
name: '{name}_sid'
triggers:
- pollscm: '*/6 * * * *'
@@ -69,6 +78,11 @@
my_distro: 'sid'
my_shell: 'debian/rules build'
my_description: 'Build the dvswitch git master branch on sid.'
+ my_trigger: 'dvswitch_stretch'
+ - '{name}_stretch':
+ my_distro: 'stretch'
+ my_shell: 'debian/rules build'
+ my_description: 'Build the dvswitch git master branch on stretch.'
my_trigger: 'dvswitch_jessie'
- '{name}_jessie':
my_distro: 'jessie'
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index 301c1dbc..0e839cab 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -37,6 +37,15 @@
- job-template:
defaults: lintian-tests
+ name: '{name}_stretch'
+ publishers:
+ - email:
+ recipients: 'jenkins+debian-qa qa-jenkins-scm@lists.alioth.debian.org lintian-maint@debian.org'
+ - trigger:
+ project: '{my_trigger}'
+
+- job-template:
+ defaults: lintian-tests
name: '{name}_jessie'
publishers:
- email:
@@ -62,7 +71,12 @@
my_distro: 'sid'
my_shell: 'timeout 6h debian/rules runtests'
my_description: 'Debian/Lintian testsuite running on sid.'
- my_trigger: 'lintian-tests_jessie'
+ my_trigger: 'lintian-tests_stretch'
+ - '{name}_stretch':
+ my_distro: 'stretch'
+ my_shell: 'timeout 6h debian/rules runtests'
+ my_description: 'Debian/Lintian testsuite running on stretch.'
+ my_trigger: 'lintian-tests_wheezy'
- '{name}_jessie':
my_distro: 'jessie'
my_shell: 'timeout 6h debian/rules runtests'
diff --git a/job-cfg/piuparts.yaml b/job-cfg/piuparts.yaml
index 05ee4b25..7151e9e5 100644
--- a/job-cfg/piuparts.yaml
+++ b/job-cfg/piuparts.yaml
@@ -37,6 +37,17 @@
- job-template:
defaults: piuparts
+ name: '{name}_testsuite_stretch'
+ publishers:
+ - email:
+ recipients: 'jenkins+debian-qa qa-jenkins-scm@lists.alioth.debian.org piuparts-devel@lists.alioth.debian.org'
+ - trigger:
+ project: '{my_trigger}'
+ builders:
+ - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
+
+- job-template:
+ defaults: piuparts
name: '{name}_testsuite_sid'
triggers:
- pollscm: '*/6 * * * *'
@@ -62,6 +73,20 @@
- job-template:
defaults: piuparts
+ name: '{name}_build_stretch'
+ publishers:
+ - email:
+ recipients: 'jenkins+debian-qa qa-jenkins-scm@lists.alioth.debian.org piuparts-devel@lists.alioth.debian.org'
+ - trigger:
+ project: '{my_trigger}'
+ - archive:
+ artifacts: '*_*.dsc, *_*.tar.*, *_*_*.deb, *_*_*.changes'
+ latest_only: true
+ builders:
+ - shell: 'export ARTIFACTS=true ; /srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
+
+- job-template:
+ defaults: piuparts
name: '{name}_build_sid'
publishers:
- email:
@@ -81,7 +106,12 @@
my_distro: 'sid'
my_shell: 'make check'
my_description: 'run testsuite from piuparts develop branch on sid.'
- my_trigger: 'piuparts_testsuite_jessie, piuparts_build_sid'
+ my_trigger: 'piuparts_testsuite_stretch, piuparts_build_sid'
+ - '{name}_testsuite_stretch':
+ my_distro: 'stretch'
+ my_shell: 'make check'
+ my_description: 'run testsuite from piuparts develop branch on stretch.'
+ my_trigger: 'piuparts_testsuite_jessie'
- '{name}_testsuite_jessie':
my_distro: 'jessie'
my_shell: 'make check'
@@ -90,6 +120,11 @@
my_distro: 'sid'
my_shell: 'debuild -uc -us'
my_description: 'build the piuparts develop branch on sid.'
+ my_trigger: 'piuparts_build_stretch'
+ - '{name}_build_stretch':
+ my_distro: 'stretch'
+ my_shell: 'debuild -uc -us'
+ my_description: 'build the piuparts develop branch on stretch.'
my_trigger: 'piuparts_build_jessie'
- '{name}_build_jessie':
my_distro: 'jessie'
diff --git a/job-cfg/udd.yaml b/job-cfg/udd.yaml
index 3fc39a3d..d4bde54f 100644
--- a/job-cfg/udd.yaml
+++ b/job-cfg/udd.yaml
@@ -43,6 +43,10 @@
- job-template:
defaults: udd
+ name: '{name}_stretch_multiarch_versionskew'
+
+- job-template:
+ defaults: udd
name: '{name}_sid_multiarch_versionskew'
- job-template:
@@ -61,6 +65,11 @@
my_params: 'multiarch_versionskew wheezy'
my_description: 'Detect multi-arch versions skews in wheezy.'
my_logparser: 'true'
+ - '{name}_stretch_multiarch_versionskew':
+ my_time: '1 8 * * *'
+ my_params: 'multiarch_versionskew stretch'
+ my_description: 'Detect multi-arch versions skews in stretch.'
+ my_logparser: 'true'
- '{name}_jessie_multiarch_versionskew':
my_time: '1 8 * * *'
my_params: 'multiarch_versionskew jessie'