summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-12-18 15:16:40 +0100
committerHolger Levsen <holger@layer-acht.org>2012-12-18 15:16:40 +0100
commit80051ba36998ef0fdbd111d9cdc26c3b955c93ef (patch)
treeb44ea1fb2e6d8c0e392f73a6447e410c96041b0f /debian/rules
parente7555e0816d50eb923ab21453f047a2a28d04d82 (diff)
downloadjenkins.debian.net-80051ba36998ef0fdbd111d9cdc26c3b955c93ef.tar.xz
further improve debian packaging: build docs
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 15 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 571f404a..a2080319 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,5 +3,19 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
+ASCIIDOC_PARAMS = "-a numbered -a data-uri -a iconsdir=/etc/asciidoc/images/icons -a scriptsdir=/etc/asciidoc/javascripts -b html5 -a toc -a toclevels=4 -a icons -a stylesheet=$(shell pwd)/theme/debian-asciidoc.css"
+
%:
- dh $@
+ dh $@
+
+override_dh_auto_build:
+ asciidoc $(ASCIIDOC_PARAMS) -o about.html README
+ asciidoc $(ASCIIDOC_PARAMS) -o todo.html TODO
+ asciidoc $(ASCIIDOC_PARAMS) -o setup.html INSTALL
+ mv *html userContent/
+ dh_auto_build
+
+override_dh_auto_clean:
+ rm -vf userContent/*.html
+ dh_auto_clean
+