summaryrefslogtreecommitdiffstats
path: root/bin/reproducible_html_packages.py
diff options
context:
space:
mode:
authorChris Lamb <lamby@debian.org>2015-08-24 22:13:38 +0200
committerHolger Levsen <holger@layer-acht.org>2015-08-24 22:13:38 +0200
commit20f971698b61274edf94b380af1b3920bdb145ee (patch)
tree2f5d211092f4645f478f029b67d58f62544bf5dc /bin/reproducible_html_packages.py
parent0fb79a61be232db9ac5764ec51ce4fe764fa20ff (diff)
downloadjenkins.debian.net-20f971698b61274edf94b380af1b3920bdb145ee.tar.xz
reproducible: Don't open external resources in our iframe
It's considered poor web etiquette to hijack links to cross-domain resources - the default "click" should take me to, eg. bugs.debian.org, and it can be quite annoying when it doesn't and I need to renavigate to get the URL, etc. Futhermore, when the iframe goes away we will have this behaviour anyway, so not only can we do the right thing now, we can avoid changing habits in the future after people are used or working around it. Signed-off-by: Chris Lamb <lamby@debian.org>
Diffstat (limited to 'bin/reproducible_html_packages.py')
-rwxr-xr-xbin/reproducible_html_packages.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/bin/reproducible_html_packages.py b/bin/reproducible_html_packages.py
index 91590589..2f88760c 100755
--- a/bin/reproducible_html_packages.py
+++ b/bin/reproducible_html_packages.py
@@ -28,16 +28,16 @@ html_package_page = Template((tab*2).join(("""
$links
</ul></li>
<li>
- <a href="https://tracker.debian.org/$package" target="main">PTS</a>
- <a href="https://bugs.debian.org/src:$package" target="main">BTS</a>
+ <a href="https://tracker.debian.org/$package">PTS</a>
+ <a href="https://bugs.debian.org/src:$package">BTS</a>
</li>
<li>
- <a href="https://sources.debian.net/src/$package/$version/" target="main">sources</a>
- <a href="https://sources.debian.net/src/$package/$version/debian" target="main">debian/</a>
+ <a href="https://sources.debian.net/src/$package/$version/">sources</a>
+ <a href="https://sources.debian.net/src/$package/$version/debian">debian/</a>
<ul class="children">
- <li><a href="https://sources.debian.net/src/$package/$version/debian/changelog" target="main">changelog</a></li>
- <li><a href="https://sources.debian.net/src/$package/$version/debian/control" target="main">control</a></li>
- <li><a href="https://sources.debian.net/src/$package/$version/debian/rules" target="main">rules</a></li>
+ <li><a href="https://sources.debian.net/src/$package/$version/debian/changelog">changelog</a></li>
+ <li><a href="https://sources.debian.net/src/$package/$version/debian/control">control</a></li>
+ <li><a href="https://sources.debian.net/src/$package/$version/debian/rules">rules</a></li>
</ul>
</li>
</ul>