summaryrefslogtreecommitdiffstats
path: root/TODO
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2015-10-16 15:07:21 +0200
committerHolger Levsen <holger@layer-acht.org>2015-10-16 15:07:21 +0200
commite31e919e1acbab7f4f3cfe8a970edcfbf43da19f (patch)
tree4228d5b88ef733bfa5477e654f527498a5bd0b9b /TODO
parent01f43b9f93b2d19e4dd1ab34d3126be9bcab224d (diff)
downloadjenkins.debian.net-e31e919e1acbab7f4f3cfe8a970edcfbf43da19f.tar.xz
reproducible: first stab at setting up an archlinux build schroot
Diffstat (limited to 'TODO')
-rw-r--r--TODO29
1 files changed, 8 insertions, 21 deletions
diff --git a/TODO b/TODO
index 548aa368..7f0da5ac 100644
--- a/TODO
+++ b/TODO
@@ -293,28 +293,20 @@ properties:
==== reproducible Arch Linux
* create a job, to bootstrap an arch schroot:
+* use regular maintenace job to update the arch schroot
+* create another job, to build a single package and a webpage for it…
----
- curl -O https://mirrors.kernel.org/archlinux/iso/2015.08.01/archlinux-bootstrap-2015.08.01-x86_64.tar.gz
- tar xzf archlinux-bootstrap-2015.08.01-x86_64.tar.gz
- mv /srv/workspace/arch/root.x86_64/ /schroots/reproducible-arch
- sudo vi /etc/schroot/chroot.d/jenkins-reproducible-arch
- as jenkins:
- schroot --directory /tmp -c source:jenkins-reproducible-arch -u root bash
- pacman-key --init
- pacman-key --populate archlinux
- echo 'Server = http://mirror.one.com/archlinux/$repo/os/$arch' >> /etc/pacman.d/mirrorlist
- schroot --directory /tmp -c source:jenkins-reproducible-arch -u root -- pacman -Syu --noconfirm
- schroot --directory /tmp -c source:jenkins-reproducible-arch -u root -- pacman -S --noconfirm devtools abs base-devel
- schroot --directory /tmp -c source:jenkins-reproducible-arch -u root -- abs
- schroot --directory /tmp -c source:jenkins-reproducible-arch mkdir /var/lib/jenkins
- schroot --directory /tmp -c source:jenkins-reproducible-arch chown jenkins:jenkins /var/lib/jenkins
- schroot --directory /tmp -c source:jenkins-reproducible-arch -- gpg --recv-keys 0x091AB856069AAA1C
PKG=sudo
schroot --directory /tmp -c source:jenkins-reproducible-arch -- cp -r /var/abs/core/$PKG /tmp
schroot --directory /tmp -c source:jenkins-reproducible-arch -- grep ^validpgpkeys= $PKG/PKGBUILD|cut -d "'" -f2|xargs schroot --directory /tmp -c source:jenkins-reproducible-arch -- gpg --recv-keys
schroot --directory /tmp/$PKG -c source:jenkins-reproducible-arch -- makepkg --skippgpcheck # YOLO
-
+----
+* create a simple scheduler and build a few more packages…
+** schroot, find packages in /var/abs/core/, schedule those
+*** idea: reschedule reverse build depends too
+* more random notes:
+----
# todo:
use -source schroot
download bootstrap.tar.gz sig and verify
@@ -329,11 +321,6 @@ properties:
echo 'keyserver-options auto-key-retrieve' >> ~/.gnupg/gpg.conf
patch pacman to create .buildinfo files - or better: wait
----
-* use regular maintenace job to update the arch schroot
-* create another job, to build a single package and a webpage for it…
-* create a simple scheduler and build a few more packages…
-** schroot, find packages in /var/abs/core/, schedule those
-*** idea: reschedule reverse build depends too
==== reproducible...