diff options
author | Holger Levsen <holger@layer-acht.org> | 2015-07-08 16:16:09 +0200 |
---|---|---|
committer | Holger Levsen <holger@layer-acht.org> | 2015-07-08 16:16:09 +0200 |
commit | cfe46e6b0cdf163f94a96237c4744bda450e227c (patch) | |
tree | 0cf83540164703ef6764f480be598579ac2ba534 | |
parent | 2220c23fcfafddb34b47ea682da82838fe976808 (diff) | |
download | jenkins.debian.net-cfe46e6b0cdf163f94a96237c4744bda450e227c.tar.xz |
reproducible: add maint_lua package set
-rw-r--r-- | TODO | 1 | ||||
-rwxr-xr-x | bin/reproducible_common.sh | 1 | ||||
-rwxr-xr-x | bin/reproducible_create_meta_pkg_sets.sh | 11 |
3 files changed, 12 insertions, 1 deletions
@@ -202,7 +202,6 @@ properties: * pkg sets related: ** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential) ** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control -** add lua package set (all packages build-depending on dh-lua and starting with lua*) * missing tests: ** variation in kernel diff --git a/bin/reproducible_common.sh b/bin/reproducible_common.sh index 5a7f51ec..d904191b 100755 --- a/bin/reproducible_common.sh +++ b/bin/reproducible_common.sh @@ -91,6 +91,7 @@ META_PKGSET[25]="maint_pkg-javascript-devel" META_PKGSET[26]="maint_debian-boot" META_PKGSET[27]="maint_debian-ocaml" META_PKGSET[28]="maint_debian-x" +META_PKGSET[29]="maint_lua" schedule_packages() { LC_USER="$REQUESTER" \ diff --git a/bin/reproducible_create_meta_pkg_sets.sh b/bin/reproducible_create_meta_pkg_sets.sh index 1338bdf9..4fbd9ad5 100755 --- a/bin/reproducible_create_meta_pkg_sets.sh +++ b/bin/reproducible_create_meta_pkg_sets.sh @@ -368,6 +368,17 @@ update_pkg_sets() { update_if_similar ${META_PKGSET[28]}.pkgset fi + # lua packages + if [ ! -z $(find $TPATH -maxdepth 1 -mtime +0 -name ${META_PKGSET[29]}.pkgset) ] || [ ! -f $TPATH/${META_PKGSET[29]}.pkgset ] ; then + # get a bunch of binary packages names and convert them to source package names + grep-dctrl -sPackage -n -FPackage -e ^lua.* $PACKAGES > $TMPFILE + packages_list_to_deb822 + convert_from_deb822_into_source_packages_only + # add some more source package names + grep-dctrl -sPackage -n -FBuild-Depends dh-lua $SOURCES | sed "s#([^()]*)##g ; s#\[[^][]*\]##g ; s#,##g" | sort -u >> $TMPFILE + update_if_similar ${META_PKGSET[29]}.pkgset + fi + } TMPFILE=$(mktemp --tmpdir=$TEMPDIR pkg-sets-XXXXXXXXX) |