From ac8291a5dcbfe9edf53d627be1139fe52708d4ce Mon Sep 17 00:00:00 2001
From: eliott
Date: Sat, 22 Sep 2007 12:09:00 -0700
Subject: Changes to bring the main arch site theme to the aur.
---
.gitignore | 3 +
web/html/css/arch.css | 449 +++++++++++++++++++++++++++++++++++++++++
web/html/images/logo.png | Bin 0 -> 15730 bytes
web/html/images/tab.png | Bin 0 -> 107 bytes
web/html/images/title.png | Bin 0 -> 6465 bytes
web/html/images/title_back.png | Bin 0 -> 168 bytes
web/lang/en/pkgfuncs_po.inc | 4 +-
web/lib/aur.inc | 166 +++++++--------
web/lib/pkgfuncs.inc | 360 ++++++++++++++-------------------
9 files changed, 676 insertions(+), 306 deletions(-)
create mode 100644 .gitignore
create mode 100644 web/html/css/arch.css
create mode 100644 web/html/images/logo.png
create mode 100644 web/html/images/tab.png
create mode 100644 web/html/images/title.png
create mode 100644 web/html/images/title_back.png
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..9e572ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.swp
+web/lib/config.inc
+
diff --git a/web/html/css/arch.css b/web/html/css/arch.css
new file mode 100644
index 0000000..7d8f41f
--- /dev/null
+++ b/web/html/css/arch.css
@@ -0,0 +1,449 @@
+* { margin: 0; padding: 0; }
+* ul { padding: 20px; }
+body {
+ background: url("/images/title_back.png") repeat-x top left #fbf8f1;
+ padding: 0 30px;
+ color: #46494d;
+ font-family: Bitstream Vera Sans, Lucida Grande, Arial, sans-serif;
+}
+/*
+ * Divs
+ */
+#head_container {
+ height: 175px;
+}
+#main_nav ul {
+ list-style: none;
+ padding-right: 10px;
+ padding-top: 48px;
+}
+#main_nav ul li {
+ display: block;
+ float: right;
+ width: 67px;
+ height: 20px;
+ padding-top: 2px;
+ margin-left: 3px;
+ background: url("/images/tab.png") repeat-x bottom left #fbf8f1;
+ text-align: center;
+ font-size: 13px;
+}
+#main_nav ul li[class~=selected] {
+ background: #fbf8f1;
+}
+#main_nav ul li a {
+ text-decoration: none;
+}
+#sub_nav ul {
+ list-style: none;
+ padding-right: 10px;
+ padding-top: 5px;
+}
+#sub_nav ul li {
+ display: block;
+ float: right;
+ width: 87px;
+ height: 20px;
+ padding-top: 2px;
+ margin-left: 3px;
+ background: url("/images/tab.png") repeat-x bottom left #fbf8f1;
+ border: 1px solid #cccccc;
+ text-align: center;
+ font-size: 13px;
+}
+#sub_nav ul li[class~=selected] {
+ background: #fbf8f1;
+}
+#sub_nav ul li a {
+ text-decoration: none;
+}
+
+#lang_sub {
+ display: block;
+ position: absolute;
+ top: 0;
+ right: 20px;
+}
+#lang_sub ul {
+ list-style: none;
+}
+#lang_sub ul a {
+ text-decoration: none;
+ color: #000000;
+}
+#lang_sub ul a:hover {
+ color: #FF0000;
+}
+#lang_sub ul li {
+ display: block;
+ float: right;
+ margin-left: 6px;
+ font-size: 10px;
+ text-align: center;
+}
+
+#title {
+ height: 140px;
+ float: left;
+}
+#updates {
+ font-size: small;
+ /*position: relative;*/
+ top: 0px;
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+ padding: 10px;
+}
+#ads {
+ float: right;
+}
+#logo {
+ float: left;
+ width: 140px;
+ height: 140px;
+}
+#titleimg {
+ float: left;
+}
+#devlist {
+ width: 80%;
+ padding: 10px;
+ margin-left: auto;
+ margin-right: auto;
+ border-top: 1px dashed black;
+ border-bottom: 1px dashed black;
+ text-align: center;
+}
+.clear {
+ clear: both;
+ margin: 0;
+ padding: 0;
+}
+.right {
+ float: right;
+ width: 320px;
+ padding: 0 10px 10px 0;
+}
+.left {
+ padding: 10px;
+ margin: 0 360px 0 0;
+}
+.left p {
+ text-align: justify;
+ padding-bottom: 10px;
+}
+.box {
+ padding: 10px;
+ background: #e1e3e6;
+ border: 1px solid #8faecd;
+}
+.greybox {
+ padding: 10px;
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+}
+div.listing {
+ padding-right: 10px;
+ border-left: 1px solid #387cbf;
+}
+.error {
+ color: #dd0000;
+ font-size: small;
+}
+.foot {
+ clear: both;
+ text-align: center;
+ font-size: 0.8em;
+}
+#search {
+ float: right;
+ position: relative;
+ top: -2em;
+ font-size: 0.8em;
+}
+#search input {
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+}
+.smalltext {
+ text-align: right;
+ font-size: x-small;
+}
+/*
+ * Headers
+ */
+h2 {
+ margin: 20px 0 10px 0;
+}
+h2.title {
+ border-bottom: 1px solid #46494d;
+}
+h3 {
+ margin-bottom: 10px;
+}
+h3.title {
+ text-align: right;
+ border-bottom: 1px solid #46494d;
+}
+h4.title {
+ text-align: left;
+ border-bottom: 1px solid #46494d;
+}
+h4.news {
+ border-bottom: 1px dotted #8faecd;
+}
+div.listing h4 {
+ background: #d1d3d6;
+ border-top: 1px double #387cbf;
+ padding: 3px;
+}
+/*
+ * Paragraphs, Anchors, Images
+ */
+p {
+ padding-bottom: 20px;
+}
+p.news {
+ text-align: left;
+ font-size: small;
+}
+a {
+ color: #35526f;
+ font-weight: bold;
+ text-decoration: underline;
+}
+.news a {
+ text-decoration: none;
+}
+#about {
+ position: relative;
+ top: -9px;
+}
+#about a {
+ text-decoration: none;
+}
+.community a {
+ text-decoration: none;
+}
+ol {
+ padding-left: 45px;
+}
+ul.small {
+ list-style: none;
+ font-size: x-small;
+}
+ul.links {
+ list-style: none;
+ font-size: small;
+ padding: 0px 0px 20px 20px;
+}
+img {
+ border: none;
+}
+hr {
+ border: none;
+ border-top: 1px solid #46494d;
+}
+.greybox input, button, textarea, select {
+ background: #e1e3e6;
+ border: 1px solid #8faecd;
+}
+.box input, button {
+ padding: 2px;
+ background: #c1c3f6;
+ font-size: x-small;
+ border: 1px solid #8faecd;
+}
+button#f_trigger {
+ background: #e1e3e6;
+}
+/*
+ * Table stuff
+ */
+table.center {
+ margin-left: auto;
+ margin-right: auto;
+}
+table#releases {
+ font-size: small;
+ width: 100%;
+}
+table#releases td {
+ padding-right: 20px;
+}
+table#repolinks {
+ font-size: small;
+ width: 100%;
+}
+table#repolinks td {
+ text-align: right;
+}
+table#repolinks th {
+ text-align: left;
+}
+table#art {
+ text-align: center;
+ margin-left: auto;
+ margin-right: auto;
+}
+.devpic {
+ vertical-align: top;
+ padding-right: 15px;
+}
+table.deventry {
+ padding-bottom: 25px;
+}
+.deventry th {
+ text-align: left;
+ vertical-align: top;
+ white-space: nowrap;
+}
+.deventry td {
+ border-bottom: 1px solid black;
+ width: 100%;
+}
+table.results {
+ padding: 0px;
+ border-collapse: collapse;
+}
+.results th {
+ background: #e1e3e6;
+ border-bottom: 1px solid #46494d;
+ border-top: 1px solid #46494d;
+ text-align: left;
+ padding-top: 0px;
+ padding-bottom: 0px;
+ padding-right: 5px;
+}
+.results th>a {
+ text-decoration: none;
+ color: #46494d;
+}
+.results td {
+ padding-right: 5px;
+ vertical-align: top;
+ font-size: 0.8em;
+}
+.listing th {
+ background: #d1d3d6;
+ border-left: 1px solid #387cbf;
+ font-size: small;
+ vertical-align: top;
+ text-align: left;
+ padding: 2px;
+}
+.listing td {
+ font-size: small;
+ padding: 2px;
+}
+blockquote.code {
+ background: #c1c3f6;
+ border: 1px solid #8faecd;
+ margin-left: auto;
+ margin-right: auto;
+ white-space: nowrap;
+ padding: 5px;
+ font-family: Courier, Courier New, Monospace;
+}
+/*
+ * Wiki Styles
+ */
+h1.wiki {
+ border-bottom: 1px solid #46494d;
+}
+div.wikifoot_l {
+ font-size: x-small;
+ text-align: left;
+ padding-top: 25px;
+}
+div.wikifoot_r {
+ font-size: x-small;
+ text-align: right;
+ float: right;
+ padding-top: 25px;
+}
+.wikibody {
+ padding-top: 15px;
+}
+.wikibody ol {
+ padding-left: 28px;
+ padding-top: 0px;
+}
+.wikibody ul {
+ padding-left: 25px;
+ padding-top: 0px;
+}
+.wikibody dd {
+ padding-left: 30px;
+}
+.wikibody pre code {
+ background: #c1c3f6;
+ border: 1px solid #8faecd;
+ margin-left: auto;
+ margin-right: auto;
+ white-space: nowrap;
+ padding: 5px;
+ font-family: Courier, Courier New, Monospace;
+}
+.wikibody blockquote {
+ padding-left: 30px;
+}
+.wikibody td {
+ padding: 5px;
+ border: 1px solid black;
+}
+
+/* Used by Django's FormWrappers */
+textarea.vLargeTextField {
+ width: 450px;
+ height: 250px;
+}
+.pkgr2 {
+ background-color: #eee4cb;
+}
+#maincontent {
+ width: 100%;
+ text-align: left;
+}
+#maincontent > table {
+ width: 90%;
+ margin-left: 5%;
+ margin-right: 5%;
+}
+.pkgbox {
+ width: 90%;
+ margin-left: 5%;
+ margin-right: 5%;
+ background-color: #ffffff;
+ border-width: 2px;
+ border-color: #dddddd;
+ border-style: solid;
+ text-align: left;
+ padding: 3px;
+}
+.pkgboxtitle {
+ border-width: 2px;
+ border-style: solid;
+ border-color: #dddddd;
+ border-top-width: 1px;
+ border-top-color: #ffffff;
+ border-left-width: 1px;
+ border-left-color: #ffffff;
+ background-color: #f1f2f4;
+ text-align: right;
+ padding-top: 2px;
+ padding-bottom: 2px;
+ padding-right: 10px;
+}
+.pkgboxbody, .pkgboxbody-comment {
+ padding: 10px;
+}
+.pkgboxbody input {
+ margin-right: 10px;
+}
+
+.pkgboxbody-comment > table {
+ border-collapse: separate;
+ border-spacing: 0 15px;
+}
+
diff --git a/web/html/images/logo.png b/web/html/images/logo.png
new file mode 100644
index 0000000..b2b6d86
Binary files /dev/null and b/web/html/images/logo.png differ
diff --git a/web/html/images/tab.png b/web/html/images/tab.png
new file mode 100644
index 0000000..56d2e61
Binary files /dev/null and b/web/html/images/tab.png differ
diff --git a/web/html/images/title.png b/web/html/images/title.png
new file mode 100644
index 0000000..e16971a
Binary files /dev/null and b/web/html/images/title.png differ
diff --git a/web/html/images/title_back.png b/web/html/images/title_back.png
new file mode 100644
index 0000000..95c98d7
Binary files /dev/null and b/web/html/images/title_back.png differ
diff --git a/web/lang/en/pkgfuncs_po.inc b/web/lang/en/pkgfuncs_po.inc
index 220cdb3..dcd46f4 100644
--- a/web/lang/en/pkgfuncs_po.inc
+++ b/web/lang/en/pkgfuncs_po.inc
@@ -31,7 +31,7 @@ $_t["en"]["Error retrieving package details."] = "Error retrieving package detai
$_t["en"]["Description"] = "Description";
-$_t["en"]["My Packages"] = "My Packages";
+$_t["en"]["My Packages"] = "My Pkgs";
$_t["en"]["Keywords"] = "Keywords";
@@ -151,4 +151,4 @@ $_t["en"]["License"] = "License";
$_t["en"]["unknown"] = "unknown";
-?>
\ No newline at end of file
+?>
diff --git a/web/lib/aur.inc b/web/lib/aur.inc
index cce5384..ce662f7 100644
--- a/web/lib/aur.inc
+++ b/web/lib/aur.inc
@@ -359,100 +359,77 @@ function html_header() {
global $_SERVER;
global $_COOKIE;
global $LANG;
- print "\n";
- print "\n";
- print "\n";
- print "\n";
- print "AUR (".$LANG.") \n";
- print " \n";
- print " \n";
- print " \n";
- print " \n";
- print " \n";
- print "\n";
- print "\n";
- print "\n";
- print " \n";
- print " \n";
- print " \n";
- print " \n";
- print " \n";
- print " \n";
-
- # Menu items
- #
- print " \n";
- print " ";
- print " .: ";
- print " ".__("Home")." ";
- print " - ";
- print " ".__("Accounts")." ";
- print " - ";
- print " ".__("Packages")." ";
+ echo "\n";
+ echo "\n";
+ echo "\n";
+ echo "\n";
+ echo "AUR (".$LANG.") \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo "\n";
+ echo "\n";
+ echo <<
+
+
+
+
+
+
+
+END1;
if ($_COOKIE["AURSID"]) {
- # Only display these items if the visitor is logged in. This should
- # be a safe check because check_sid() has been called prior to
- # html_header().
- #
- print " - ";
- print " ".__("Submit")." ";
+ # This is a usability change, so we can go to My Packages page
+ # with just one click
+ # Added by: dsa
+ echo ' '.__("Logout")." \n";
+ echo ' '.__("Submit")." \n";
+ echo ' '.__("My Packages")." \n";
}
- print " - ";
- print " ".__("Bugs")." ";
- print " - ";
- print " ".__("Discussion")." ";
- if ($_COOKIE["AURSID"]) {
- # This is a usability change, so we can go to My Packages page
- # with just one click
- # Added by: dsa
- print " - ";
- print " ".__("My Packages")." ";
-
- print " - ";
- print " ".__("Logout")." ";
- }
- print " :. ";
- print " ";
- print " ";
- print " \n";
- print " \n";
- print " \n";
- print "\n\n";
-
- return;
+ echo ' '.__("Discussion")." \n";
+ echo ' '.__("Bugs")." \n";
+ echo ' '.__("Packages")." \n";
+ echo ' '.__("Accounts")." \n";
+ echo ' AUR-'.__("Home")." \n";
+ echo " \n";
+ echo " \n";
+ echo ' '."\n";
+ echo "
\n";
+ echo " RU \n";
+ echo " FR \n";
+ echo " DE \n";
+ echo " ES \n";
+ echo " PT \n";
+ echo " CA \n";
+ echo " IT \n";
+ echo " PL \n";
+ echo " EN \n";
+ echo " Lang: \n";
+ echo " \n";
+ echo "
\n";
+ echo "\n";
+ echo "\n";
+ echo "\n\n";
+ return;
}
@@ -461,9 +438,6 @@ function html_header() {
function html_footer($ver="") {
print "\n\n\n";
print " \n";
- print "
\n";
- print " \n";
- print "
\n";
if ($ver) {
print "\n";
print "
\n";
@@ -471,7 +445,7 @@ function html_footer($ver="") {
print "
\n";
print "
\n";
}
- print " \n";
+ print "\n";
print "\n";
return;
}
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index b9ad0d4..de1dc5f 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -268,36 +268,19 @@ function package_details($id=0, $SID="") {
} else {
# print out package details
- #
- print " \n";
- print "\n";
- print "\n";
- print "\n";
- print " ";
- print "".__("Package Details")." \n";
- print " \n";
- print "\n";
- print " \n";
- print "\n";
- print "\n";
- print "\n";
- print " ";
- print $row["Name"] . " " . $row["Version"]." \n";
- print " \n";
- print "\n";
- print " ";
- print "".$row["URL"]." \n";
- print " \n";
- print "\n";
- print " ".$row["Description"];
- print " \n";
- print " \n";
- print "\n";
- print " ";
- print " \n";
-
- print "\n";
- print " ";
+ #
+ echo "\n";
+ echo "
".__("Package Details")."
\n";
+ echo "
\n";
+ echo "
\n";
+ echo " ";
+ echo $row["Name"] . " " . $row["Version"]." \n";
+ echo " ";
+ echo "".$row["URL"]." \n";
+ echo " ".$row["Description"];
+ echo " \n";
+ echo " \n";
+ echo " ";
if ($row["Location"] == "unsupported" and (
uid_from_sid($SID) == $row["MaintainerUID"] or
(account_from_sid($SID) == "Developer" or
@@ -309,87 +292,65 @@ function package_details($id=0, $SID="") {
} else {
$edit_cat = $row["Category"];
}
- print $row["Location"]." :: ".$edit_cat." ";
-
- print " \n";
- print "\n";
- print " ".__("Maintainer").": ";
+ echo $row["Location"]." :: ".$edit_cat." \n";
+ echo " ".__("Maintainer").": ";
if ($row["MaintainerUID"]) {
$maintainer = username_from_id($row["MaintainerUID"]);
if ($SID) {
- print "";
- print $maintainer . " ";
+ echo "";
+ echo $maintainer . " ";
} else {
- print $maintainer . "";
+ echo $maintainer . "";
}
} else {
$maintainer = "None";
- print $maintainer . "";
+ echo $maintainer . "";
}
- print " \n";
-
- print "\n";
- print " ".__("Votes").": ";
- print $row["NumVotes"] . " ";
- print " \n";
+ echo " \n";
+ echo " ".__("Votes").": ";
+ echo $row["NumVotes"] . " \n";
# In case of wanting to put a custom message
$msg = __("unknown");
$license = $row["License"] == "" ? $msg : $row["License"];
- print "\n";
- print " ".__("License").": ".$license;
- print " \n";
- print " \n";
-
- print "\n";
- print " ";
- print " \n";
+ echo " ".__("License").": ".$license;
+ echo " \n";
+ echo " \n";
# Print the timestamps for last updates
$updated_time = ($row["ModifiedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["ModifiedTS"]));
$submitted_time = ($row["SubmittedTS"] == 0) ? "(unknown)" : gmdate("r", intval($row["SubmittedTS"]));
- print "\n";
- print " ";
- print "";
- print __("Last Updated").": ".$updated_time." ";
- print __("First Submitted").": ".$submitted_time;
- print " ";
- print " \n";
- print " \n";
-
- print "\n";
- print " ";
- print " \n";
- print "\n";
- print " ";
+ echo " ";
+ echo __("Last Updated").": ".$updated_time." ";
+ echo __("First Submitted").": ".$submitted_time." \n";
+ echo " \n";
+ echo " ";
if ($row["LocationID"] == 2) {
global $URL_DIR;
$urlpath = $URL_DIR.$row["Name"]."/".$row["Name"];
- print "".__("Tarball")." :: ".__("Files")." :: PKGBUILD ";
+ echo "".__("Tarball")." :: ".__("Files")." :: PKGBUILD ";
} elseif ($row["LocationID"] == 3) {
- print "CVS";
+ echo " CVS";
}
- print " \n";
+ echo " \n";
if ($row["LocationID"] == 2) {
- print "\n";
- print " ";
+ echo " ";
if ($row["Safe"]) {
- print "".__("The above files have been verified (by %s) and are safe to use.", array(username_from_id($row["VerifiedBy"])))." ";
+ echo "".__("The above files have been verified (by %s) and are safe to use.", array(username_from_id($row["VerifiedBy"])))." ";
} else {
- print "".__("Be careful! The above files may contain malicious code that can damage your system.")." ";
- }
+ echo "".__("Be careful! The above files may contain malicious code that can damage your system.")." ";
+ }
+ echo " \n";
}
- print "\n";
- print " ";
- print " \n";
- print "\n";
- print " ";
- print "";
- print "";
- print __("Dependencies")." \n";
- print "";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " ";
+ echo __("Dependencies")." \n";
+ echo " ";
$deps = package_dependencies($row["ID"]); # $deps[0] = array('id','name', 'dummy');
while (list($k, $darr) = each($deps)) {
$url = "".$darr[1].$darr[3]." \n";
- else print "".$darr[1].$darr[3]." \n";
+ if ($darr[2] == 0) echo $url."'>".$darr[1].$darr[3]." \n";
+ else echo "".$darr[1].$darr[3]." \n";
}
- print " \n";
- print "
";
-
- print " ";
- print "";
- print "";
- print __("Sources")." \n";
- print "";
+ echo " \n";
+ echo "
\n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " ";
+ echo __("Sources")." \n";
+ echo " ";
$sources = package_sources($row["ID"]); # $sources[0] = 'src';
while (list($k, $src) = each($sources)) {
$parsed_url = parse_url($src);
if ($parsed_url['scheme'])
{
//It is an external source
- print "".$src." \n";
+ echo "".$src." \n";
}
else
{
//It is presumably an internal source
if ($row["LocationID"] == 2) {
- print "".$src." \n";
+ echo "".$src." \n";
} elseif ($row["LocationID"] == 3) {
- print "";
- print $src." \n";
+ echo "";
+ echo $src." \n";
}
}
}
- print " \n";
- print "
";
- print " \n";
- print "\n";
- print " ";
- print " \n";
- print "
\n";
- print "\n";
- print " \n";
- print " \n";
+ echo "\n";
+ echo "
\n";
+ echo "
\n";
+ echo " \n";
+ echo "
\n";
+ echo " \n";
+ echo "\n\n";
+ echo " \n\n";
- print "
\n";
# Actions Bar
#
if ($SID) {
- print "\n";
- print "".__("Actions")." \n";
- print "\n";
- print " \n";
- print "
\n";
+ echo " \n";
+ echo " \n";
+ echo "\n";
+ echo "\n \n\n";
}
# Comments
#
- print "\n";
- print "".__("Comments")." \n";
- print "\n";
- print "";
-
- print "\n";
+ echo "\n";
+ echo "
".__("Comments")."
\n";
+ echo "
\n";
+ echo "
\n";
$comments = package_comments($row["ID"]);
if (!empty($comments)) {
while (list($indx, $carr) = each($comments)) {
- print "\n";
- print " ";
- print " \n";
-
- print "\n";
- print " ";
- print "";
- print "";
+
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " ";
if (canDeleteComment($carr["ID"], account_from_sid($SID), $SID)) {
$durl = " ";
- print $durl . " ";
+ echo $durl . " ";
}
if ($SID) {
- print __("Comment by: %h%s%h on %h%s%h",
+ echo __("Comment by: %h%s%h on %h%s%h",
array("",$carr["UserName"]," ",
"",gmdate("Ymd [H:i:s]",$carr["CommentTS"])," "));
} else {
- print __("Comment by: %h%s%h on %h%s%h",
+ echo __("Comment by: %h%s%h on %h%s%h",
array("",$carr["UserName"]," ",
"",gmdate("Ymd [H:i:s]",$carr["CommentTS"])," "));
}
- print " ";
- print " ";
- print "\n";
- print str_replace("\n", " ", str_replace('"',""", htmlspecialchars(strip_tags(stripslashes($carr["Comments"])))));
- print "
\n";
- print " \n";
- print "
\n";
- print " \n";
- print " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " ";
+ echo "\n";
+ echo str_replace("\n", " ", str_replace('"',""", htmlspecialchars(strip_tags(stripslashes($carr["Comments"])))));
+ echo "
\n";
+ echo " \n";
+ echo "
\n";
+ echo " \n";
+ echo " \n";
}
}
- print "\n";
- print " ";
- print " \n";
- print "\n";
- print " ";
- print "\n";
- print " \n";
- print " ";
- print " \n";
- print " ";
- print " \n";
-
- print "
\n";
-
-
- print "
\n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo " \n";
+ echo "
\n";
+ echo " \n";
+ echo "\n";
}
}
--
cgit v1.2.3-70-g09d2
From aebdd21b58046f647c7c500dde5152ba774303ab Mon Sep 17 00:00:00 2001
From: eliott
Date: Mon, 24 Sep 2007 07:57:35 -0700
Subject: More changes to page styles.
---
web/html/account.php | 7 +++++++
web/html/css/arch.css | 20 +++++++++++++++-----
web/html/index.php | 17 ++++++++---------
web/html/pkgsubmit.php | 8 +++++---
web/lib/pkgfuncs.inc | 18 +++++++++---------
5 files changed, 44 insertions(+), 26 deletions(-)
diff --git a/web/html/account.php b/web/html/account.php
index fd9cc61..3d98171 100644
--- a/web/html/account.php
+++ b/web/html/account.php
@@ -13,6 +13,10 @@ html_header(); # print out the HTML header
# Main page processing here
#
+echo "\n";
+echo "
".__("Accounts")."
\n";
+echo "
\n";
+
if (isset($_COOKIE["AURSID"])) {
# visitor is logged in
#
@@ -148,6 +152,9 @@ if (isset($_COOKIE["AURSID"])) {
}
}
+echo "
";
+echo "
";
+
html_footer("\$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/css/arch.css b/web/html/css/arch.css
index 7d8f41f..65f3cff 100644
--- a/web/html/css/arch.css
+++ b/web/html/css/arch.css
@@ -410,7 +410,7 @@ textarea.vLargeTextField {
margin-left: 5%;
margin-right: 5%;
}
-.pkgbox {
+.pgbox {
width: 90%;
margin-left: 5%;
margin-right: 5%;
@@ -421,7 +421,17 @@ textarea.vLargeTextField {
text-align: left;
padding: 3px;
}
-.pkgboxtitle {
+.frontpgboxbody {
+ padding: 10px;
+}
+.frontpgboxbody > table {
+ width: 100%;
+}
+.boxSoftTitle {
+ text-align: right;
+}
+
+.pgboxtitle {
border-width: 2px;
border-style: solid;
border-color: #dddddd;
@@ -435,14 +445,14 @@ textarea.vLargeTextField {
padding-bottom: 2px;
padding-right: 10px;
}
-.pkgboxbody, .pkgboxbody-comment {
+.pgboxbody, .pgboxbody-comment {
padding: 10px;
}
-.pkgboxbody input {
+.pgboxbody input {
margin-right: 10px;
}
-.pkgboxbody-comment > table {
+.pgboxbody-comment > table {
border-collapse: separate;
border-spacing: 0 15px;
}
diff --git a/web/html/index.php b/web/html/index.php
index 7d28d75..d76d13d 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -79,19 +79,19 @@ if (isset($_REQUEST["user"]) || isset($_REQUEST["pass"])) {
html_header();
# Big Top Level Table (Table 1)
-print "\n";
-print "\n";
+echo "\n";
+echo "
AUR-".__("Home")."
\n";
+echo "
\n";
+echo "
\n";
+echo "\n";
# MAIN: Top Left
print "";
print "".__("Welcome to the AUR! Please read the %hAUR User Guidelines%h and %hAUR TU Guidelines%h for more information.", array('', ' ', '', ' '))." ";
print __("Contributed PKGBUILDs must conform to the %hArch Packaging Standards%h otherwise they will be deleted!", array('', ' '))."
";
-#print "".__("If you have feedback about the AUR, please leave it in %hFlyspray%h.", array('', ' '))." ";
-#print __("Email discussion about the AUR takes place on the %sTUR Users List%s.", array('', ' '))."
";
print "".__("Remember to vote for your favourite packages!")." ";
print __("The most popular packages will be provided as binary packages in [community].")."
";
-#print "".__("Though we can't vouch for their contents, we provide a %hlist of user repositories%h for your convenience.", array('', ' '))."
";
# MAIN: Top Right
print " ";
@@ -178,9 +178,6 @@ print " ";
print "
";
# End Table 2
-#print "
";
-#print "
\n";
-
# MAIN: Bottom Right
print " ";
print "
";
@@ -357,8 +354,10 @@ print "
";
print " ";
print "\n";
print "\n";
+echo "\n";
# End Table 1
-
+echo " ";
+echo "";
html_footer("Version 1.3.1 \$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 89ecfa4..24aeea5 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -9,7 +9,9 @@ include("config.inc"); # configuration file with dir locations
set_lang(); # this sets up the visitor's language
check_sid(); # see if they're still logged in
html_header(); # print out the HTML header
-print "\n";
+echo "\n";
+echo "
".__("Submit")."
\n";
+echo "
\n";
# Debugging
$DBUG = 0;
@@ -665,8 +667,8 @@ if ($_COOKIE["AURSID"]) {
print __("You must create an account before you can upload packages.");
print " \n";
}
-
-print "\n";
+echo "
\n";
+echo "
\n";
html_footer("\$Id$");
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index de1dc5f..3089ccb 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -269,9 +269,9 @@ function package_details($id=0, $SID="") {
# print out package details
#
- echo "\n";
- echo "
".__("Package Details")."
\n";
- echo "
\n";
+ echo "
\n";
+ echo "
".__("Package Details")."
\n";
+ echo "
\n";
echo "
\n";
echo " ";
echo $row["Name"] . " " . $row["Version"]." \n";
@@ -409,9 +409,9 @@ function package_details($id=0, $SID="") {
# Actions Bar
#
if ($SID) {
- echo "\n";
- echo "
".__("Actions")."
\n";
- echo "
\n";
+ echo "
\n";
+ echo "
".__("Actions")."
\n";
+ echo "
\n";
echo "
\n";
echo " \n";
echo " \n";
@@ -482,9 +482,9 @@ function package_details($id=0, $SID="") {
# Comments
#
- echo "\n";
- echo "
".__("Comments")."
\n";
- echo "
\n";
+ echo "
\n";
+ echo "
".__("Comments")."
\n";
+ echo "
\n";
echo "
\n";
$comments = package_comments($row["ID"]);
if (!empty($comments)) {
--
cgit v1.2.3-70-g09d2
From 4e4f2728c1c4e4bf030b579dc41b530b06166271 Mon Sep 17 00:00:00 2001
From: eliott
Date: Mon, 24 Sep 2007 09:23:41 -0700
Subject: Phrakture requested fonts to be more similar to main arch site. Added
css to make it similar.
---
web/html/css/containers.css | 5 +----
web/html/css/fonts.css | 9 +--------
2 files changed, 2 insertions(+), 12 deletions(-)
diff --git a/web/html/css/containers.css b/web/html/css/containers.css
index 2a0a0e4..006c4ff 100644
--- a/web/html/css/containers.css
+++ b/web/html/css/containers.css
@@ -3,7 +3,6 @@
border: 0px;
margin: 0px;
padding: 0px;
- font-family: arial,verdana,tahoma;
}
/* Main Wrapper Data Format */
@@ -182,7 +181,6 @@
td.text
{
color: #000;
- font-family: verdana;
font-size: 12px;
}
th
@@ -198,7 +196,7 @@
input,textarea,select
{
background-color: rgb(108,131,176);
- font-family: courier;
+ font-family: monospace;
font-size: 12px;
background-color: #ccc;
border: #000000 1px solid;
@@ -210,6 +208,5 @@
background-color: #fff;
color: rgb(108,131,176);
border: 1px dashed rgb(108,131,176);
- font-family: trebuchet ms, tahoma, verdana;
font-size: 12px;
}
diff --git a/web/html/css/fonts.css b/web/html/css/fonts.css
index 8a60e05..fdeddbe 100644
--- a/web/html/css/fonts.css
+++ b/web/html/css/fonts.css
@@ -2,11 +2,10 @@
span /* Applicable by default in all fonts */
{
color: #666;
- font-family: verdana, trebuchet ms, tahoma, luxi sans;
+ font-family: Bitstream Vera Sans, Lucida Grande, Arial, sans-serif;
}
span.f1 /* Important */
{
- font-family: verdana;
font-size: 20px;
letter-spacing: 1px;
}
@@ -25,13 +24,11 @@
span.f4 /* Content Text */
{
color: #444;
- font-family: verdana;
font-size: 12px;
}
span.f5 /* Content Small */
{
color: #333;
- font-family: trebuchet ms, tahoma, verdana;
font-size: 11px;
}
span.f6 /* Red Message */
@@ -55,13 +52,11 @@
span.error /* Content Text */
{
color: #900;
- font-family: verdana;
font-size: 12px;
}
span.warning /* Content Text */
{
color: #C0C000;
- font-family: verdana;
font-size: 12px;
}
@@ -95,7 +90,6 @@
color: rgb( 201, 209, 226 );
font-weight: bold;
font-size: 11px;
- font-family: tahoma, trebuchet ms, verdana;
padding-right: 8px;
word-spacing: 8px;
}
@@ -104,7 +98,6 @@
color: #fff;
font-weight: bold;
font-size: 11px;
- font-family: tahoma, trebuchet ms, verdana;
padding-right: 8px;
}
--
cgit v1.2.3-70-g09d2
\n"; - print str_replace("\n", "
\n"; - print "", str_replace('"',""", htmlspecialchars(strip_tags(stripslashes($carr["Comments"]))))); - print "
\n"; + echo str_replace("\n", "
", str_replace('"',""", htmlspecialchars(strip_tags(stripslashes($carr["Comments"]))))); + echo "