summaryrefslogtreecommitdiffstats
path: root/web
diff options
context:
space:
mode:
Diffstat (limited to 'web')
-rw-r--r--web/html/pkgsubmit.php6
1 files changed, 6 insertions, 0 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 7ae0c1c..6503c0b 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -262,6 +262,7 @@ if ($uid):
# Parse .AURINFO and overwrite PKGBUILD fields accordingly
unset($pkg_version);
$depends = array();
+ $srcinfo_pkgname_count = 0;
foreach (explode("\n", $srcinfo_raw) as $line) {
$line = trim($line);
if (empty($line) || $line[0] == '#') {
@@ -270,6 +271,11 @@ if ($uid):
list($key, $value) = explode(' = ', $line, 2);
switch ($key) {
case 'pkgname':
+ $srcinfo_pkgname_count++;
+ if ($srcinfo_pkgname_count > 1) {
+ $error = __("Error - The AUR does not support split packages!");
+ }
+ /* Fall-through case. */
case 'pkgdesc':
case 'url':
case 'license':