summaryrefslogtreecommitdiffstats
path: root/web/html
diff options
context:
space:
mode:
Diffstat (limited to 'web/html')
-rw-r--r--web/html/account.php9
-rw-r--r--web/html/css/arch.css460
-rw-r--r--web/html/css/containers.css429
-rw-r--r--web/html/css/fonts.css9
-rw-r--r--web/html/hacker.php2
-rw-r--r--web/html/images/logo.pngbin0 -> 15730 bytes
-rw-r--r--web/html/images/tab.pngbin0 -> 107 bytes
-rw-r--r--web/html/images/title.pngbin0 -> 6465 bytes
-rw-r--r--web/html/images/title_back.pngbin0 -> 168 bytes
-rw-r--r--web/html/index.php19
-rw-r--r--web/html/logout.php7
-rw-r--r--web/html/packages.php23
-rw-r--r--web/html/pkgedit.php12
-rw-r--r--web/html/pkgsubmit.php74
-rw-r--r--web/html/template.php2
-rw-r--r--web/html/timeout.php2
-rw-r--r--web/html/xml/README.txt2
17 files changed, 766 insertions, 284 deletions
diff --git a/web/html/account.php b/web/html/account.php
index fd9cc61..9caada4 100644
--- a/web/html/account.php
+++ b/web/html/account.php
@@ -13,6 +13,10 @@ html_header(); # print out the HTML header
# Main page processing here
#
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Accounts")."</span></div>\n";
+echo " <div class=\"pgboxbody\">\n";
+
if (isset($_COOKIE["AURSID"])) {
# visitor is logged in
#
@@ -148,6 +152,9 @@ if (isset($_COOKIE["AURSID"])) {
}
}
-html_footer("\$Id$");
+echo " </div>";
+echo "</div>";
+
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/css/arch.css b/web/html/css/arch.css
new file mode 100644
index 0000000..9fa38e5
--- /dev/null
+++ b/web/html/css/arch.css
@@ -0,0 +1,460 @@
+* { margin: 0; padding: 0; }
+* ul { padding: 20px; }
+body {
+ background: url("/images/title_back.png") repeat-x top left #fbf8f1;
+ padding: 0 30px;
+ color: #46494d;
+ font-family: Bitstream Vera Sans, Lucida Grande, Arial, sans-serif;
+}
+/*
+ * Divs
+ */
+#head_container {
+ height: 175px;
+}
+#main_nav ul {
+ list-style: none;
+ padding-right: 10px;
+ padding-top: 48px;
+}
+#main_nav ul li {
+ display: block;
+ float: right;
+ width: 67px;
+ height: 20px;
+ padding-top: 2px;
+ margin-left: 3px;
+ background: url("/images/tab.png") repeat-x bottom left #fbf8f1;
+ text-align: center;
+ font-size: 13px;
+}
+#main_nav ul li[class~=selected] {
+ background: #fbf8f1;
+}
+#main_nav ul li a {
+ text-decoration: none;
+}
+#sub_nav ul {
+ list-style: none;
+ padding-right: 10px;
+ padding-top: 5px;
+}
+#sub_nav ul li {
+ display: block;
+ float: right;
+ width: 87px;
+ height: 20px;
+ padding-top: 2px;
+ margin-left: 3px;
+ background: url("/images/tab.png") repeat-x bottom left #fbf8f1;
+ border: 1px solid #cccccc;
+ text-align: center;
+ font-size: 13px;
+}
+#sub_nav ul li[class~=selected] {
+ background: #fbf8f1;
+}
+#sub_nav ul li a {
+ text-decoration: none;
+}
+
+#lang_sub {
+ display: block;
+ position: absolute;
+ top: 0;
+ right: 20px;
+}
+#lang_sub ul {
+ list-style: none;
+}
+#lang_sub ul a {
+ text-decoration: none;
+ color: #000000;
+}
+#lang_sub ul a:hover {
+ color: #FF0000;
+}
+#lang_sub ul li {
+ display: block;
+ float: right;
+ margin-left: 6px;
+ font-size: 10px;
+ text-align: center;
+}
+
+#title {
+ height: 140px;
+ float: left;
+}
+#updates {
+ font-size: small;
+ /*position: relative;*/
+ top: 0px;
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+ padding: 10px;
+}
+#ads {
+ float: right;
+}
+#logo {
+ float: left;
+ width: 140px;
+ height: 140px;
+}
+#titleimg {
+ float: left;
+}
+#devlist {
+ width: 80%;
+ padding: 10px;
+ margin-left: auto;
+ margin-right: auto;
+ border-top: 1px dashed black;
+ border-bottom: 1px dashed black;
+ text-align: center;
+}
+.clear {
+ clear: both;
+ margin: 0;
+ padding: 0;
+}
+.right {
+ float: right;
+ width: 320px;
+ padding: 0 10px 10px 0;
+}
+.left {
+ padding: 10px;
+ margin: 0 360px 0 0;
+}
+.left p {
+ text-align: justify;
+ padding-bottom: 10px;
+}
+.box {
+ padding: 10px;
+ background: #e1e3e6;
+ border: 1px solid #8faecd;
+}
+.greybox {
+ padding: 10px;
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+}
+div.listing {
+ padding-right: 10px;
+ border-left: 1px solid #387cbf;
+}
+.error {
+ color: #dd0000;
+ font-size: small;
+}
+.foot {
+ clear: both;
+ text-align: center;
+ font-size: 0.8em;
+}
+#search {
+ float: right;
+ position: relative;
+ top: -2em;
+ font-size: 0.8em;
+}
+#search input {
+ background: #f6efe0;
+ border: 1px solid #eee4cb;
+}
+.smalltext {
+ text-align: right;
+ font-size: x-small;
+}
+/*
+ * Headers
+ */
+h2 {
+ margin: 20px 0 10px 0;
+}
+h2.title {
+ border-bottom: 1px solid #46494d;
+}
+h3 {
+ margin-bottom: 10px;
+}
+h3.title {
+ text-align: right;
+ border-bottom: 1px solid #46494d;
+}
+h4.title {
+ text-align: left;
+ border-bottom: 1px solid #46494d;
+}
+h4.news {
+ border-bottom: 1px dotted #8faecd;
+}
+div.listing h4 {
+ background: #d1d3d6;
+ border-top: 1px double #387cbf;
+ padding: 3px;
+}
+/*
+ * Paragraphs, Anchors, Images
+ */
+p {
+ padding-bottom: 20px;
+}
+p.news {
+ text-align: left;
+ font-size: small;
+}
+a {
+ color: #35526f;
+ font-weight: bold;
+ text-decoration: underline;
+}
+.news a {
+ text-decoration: none;
+}
+#about {
+ position: relative;
+ top: -9px;
+}
+#about a {
+ text-decoration: none;
+}
+.community a {
+ text-decoration: none;
+}
+ol {
+ padding-left: 45px;
+}
+ul.small {
+ list-style: none;
+ font-size: x-small;
+}
+ul.links {
+ list-style: none;
+ font-size: small;
+ padding: 0px 0px 20px 20px;
+}
+img {
+ border: none;
+}
+hr {
+ border: none;
+ border-top: 1px solid #46494d;
+}
+.greybox input, button, textarea, select {
+ background: #e1e3e6;
+ border: 1px solid #8faecd;
+}
+.box input, button {
+ padding: 2px;
+ background: #c1c3f6;
+ font-size: x-small;
+ border: 1px solid #8faecd;
+}
+button#f_trigger {
+ background: #e1e3e6;
+}
+/*
+ * Table stuff
+ */
+table.center {
+ margin-left: auto;
+ margin-right: auto;
+}
+table#releases {
+ font-size: small;
+ width: 100%;
+}
+table#releases td {
+ padding-right: 20px;
+}
+table#repolinks {
+ font-size: small;
+ width: 100%;
+}
+table#repolinks td {
+ text-align: right;
+}
+table#repolinks th {
+ text-align: left;
+}
+table#art {
+ text-align: center;
+ margin-left: auto;
+ margin-right: auto;
+}
+.devpic {
+ vertical-align: top;
+ padding-right: 15px;
+}
+table.deventry {
+ padding-bottom: 25px;
+}
+.deventry th {
+ text-align: left;
+ vertical-align: top;
+ white-space: nowrap;
+}
+.deventry td {
+ border-bottom: 1px solid black;
+ width: 100%;
+}
+table.results {
+ padding: 0px;
+ border-collapse: collapse;
+}
+.results th {
+ background: #e1e3e6;
+ border-bottom: 1px solid #46494d;
+ border-top: 1px solid #46494d;
+ text-align: left;
+ padding-top: 0px;
+ padding-bottom: 0px;
+ padding-right: 5px;
+}
+.results th>a {
+ text-decoration: none;
+ color: #46494d;
+}
+.results td {
+ padding-right: 5px;
+ vertical-align: top;
+ font-size: 0.8em;
+}
+.listing th {
+ background: #d1d3d6;
+ border-left: 1px solid #387cbf;
+ font-size: small;
+ vertical-align: top;
+ text-align: left;
+ padding: 2px;
+}
+.listing td {
+ font-size: small;
+ padding: 2px;
+}
+blockquote.code {
+ background: #c1c3f6;
+ border: 1px solid #8faecd;
+ margin-left: auto;
+ margin-right: auto;
+ white-space: nowrap;
+ padding: 5px;
+ font-family: Courier, Courier New, Monospace;
+}
+/*
+ * Wiki Styles
+ */
+h1.wiki {
+ border-bottom: 1px solid #46494d;
+}
+div.wikifoot_l {
+ font-size: x-small;
+ text-align: left;
+ padding-top: 25px;
+}
+div.wikifoot_r {
+ font-size: x-small;
+ text-align: right;
+ float: right;
+ padding-top: 25px;
+}
+.wikibody {
+ padding-top: 15px;
+}
+.wikibody ol {
+ padding-left: 28px;
+ padding-top: 0px;
+}
+.wikibody ul {
+ padding-left: 25px;
+ padding-top: 0px;
+}
+.wikibody dd {
+ padding-left: 30px;
+}
+.wikibody pre code {
+ background: #c1c3f6;
+ border: 1px solid #8faecd;
+ margin-left: auto;
+ margin-right: auto;
+ white-space: nowrap;
+ padding: 5px;
+ font-family: Courier, Courier New, Monospace;
+}
+.wikibody blockquote {
+ padding-left: 30px;
+}
+.wikibody td {
+ padding: 5px;
+ border: 1px solid black;
+}
+
+/* Used by Django's FormWrappers */
+textarea.vLargeTextField {
+ width: 450px;
+ height: 250px;
+}
+.pkgr2 {
+ background-color: #eee4cb;
+}
+#maincontent {
+ width: 100%;
+ text-align: left;
+}
+#maincontent > table {
+ width: 90%;
+ margin-left: 5%;
+ margin-right: 5%;
+}
+.pgbox {
+ width: 90%;
+ margin-left: 5%;
+ margin-right: 5%;
+ background-color: #ffffff;
+ border-width: 2px;
+ border-color: #dddddd;
+ border-style: solid;
+ text-align: left;
+ padding: 3px;
+}
+.frontpgboxbody {
+ padding: 10px;
+}
+.frontpgboxbody > table {
+ width: 100%;
+}
+.boxSoftTitle {
+ text-align: right;
+}
+
+.pgboxtitle {
+ border-width: 2px;
+ border-style: solid;
+ border-color: #dddddd;
+ border-top-width: 1px;
+ border-top-color: #ffffff;
+ border-left-width: 1px;
+ border-left-color: #ffffff;
+ background-color: #f1f2f4;
+ text-align: left;
+ padding-top: 2px;
+ padding-bottom: 2px;
+ padding-right: 10px;
+ padding-left: 10px;
+}
+.pgboxbody, .pgboxbody-comment {
+ padding: 10px;
+}
+.pgboxbody input {
+ margin-right: 10px;
+}
+
+.pgboxbody-comment > table {
+ border-collapse: separate;
+ border-spacing: 0 15px;
+}
+
diff --git a/web/html/css/containers.css b/web/html/css/containers.css
index 2a0a0e4..e42bd5a 100644
--- a/web/html/css/containers.css
+++ b/web/html/css/containers.css
@@ -1,215 +1,214 @@
- body,table,td,img
- {
- border: 0px;
- margin: 0px;
- padding: 0px;
- font-family: arial,verdana,tahoma;
- }
-
-/* Main Wrapper Data Format */
- td.preHeader
- {
- background-color: #000;
- border-bottom: 1px solid rgb( 69, 84, 113 );
- height: 16px;
- text-align: right;
- }
- td.headerFill
- {
- background-color: rgb( 108, 131, 176 );
- border-bottom: 1px solid #000;
- }
- td.headerDisplay
- {
- background-color: rgb( 108, 131, 176 );
- padding-left: 16px;
- }
- td.mainLinks
- {
- background-color: #eee;
- border-bottom: 1px solid #000;
- height: 22px;
- padding-left: 12px;
- }
- td.sideBar
- {
- background-color: #fff;
- text-align: center;
- vertical-align: top;
- width: 150px;
- }
- td.sideBarGrey
- {
- background-color: #eee;
- border-bottom: 1px solid #000;
- text-align: left;
- vertical-align: top;
- width: 150px;
- }
- td.sideBarSmall
- {
- background-color: rgb( 108, 131, 176 );
- border-bottom: 1px solid #000;
- height: 16px;
- text-align: right;
- width: 150px;
- }
- td.sideBarSmallHeader
- {
- background-color: rgb(108,131,176);
- vertical-align: top;
- height: 16px;
- padding-top: 1px;
- padding-bottom: 2px;
- text-align: right;
- width: 150px;
- }
- td.subLinks
- {
- background-color: rgb( 225, 228, 232 );
- border-right: 1px solid #000;
- color: rgb( 120, 120, 120 );
- padding-left: 12px;
- height: 19px;
- }
- td.contentDisplay
- {
- background-color: #ffffff;
- border-right: 1px solid #000;
- border-left: 1px solid #000;
- border-bottom: 1px solid #000;
- text-align: center;
- vertical-align: top;
- padding: 10;
- }
-
- td.footerDisplay
- {
- background-color: #eee;
- border-bottom: 1px solid #000;
- text-align: center;
- }
-
-/* Containers Used Globally */
- table.boxSoft
- {
- width: 90%;
- background-color: #ddd;
- text-align: left;
- }
- td.boxSoft
- {
- background-color: #fff;
- padding: 10;
- text-align: left;
- }
- td.boxSoftColumn
- {
- padding-left: 16;
- padding-right: 16;
- text-align: justify;
- vertical-align: top;
- text-indent: 20px;
- }
- td.div
- {
- background-color: #eee;
- width: 3px;
- }
- td.boxSoftTitle
- {
- border-bottom: 1px solid #fff;
- border-top: 1px solid #fff;
- background-color: rgb( 241, 242, 244 );
- padding-left: 10;
- padding-top: 1;
- padding-bottom: 1;
- }
- table.boxSoftSmall
- {
- width: 94%;
- background-color: #ddd;
- }
- td.boxSoftSmall
- {
- background-color: #fff;
- text-align: center;
- padding-top: 2;
- padding-bottom: 2;
- }
- td.boxSoftSmallTitle
- {
- border-bottom: 1px solid #ccc;
- background-color: rgb( 241, 242, 244 );
- padding-left: 10;
- }
- td.ss /* ss = small space */
- {
- padding-left: 6px;
- vertical-align: top;
- }
- td.display
- {
- border-bottom: 1px solid #000;
- padding-bottom: 6px;
- }
- td.features
- {
- padding: 4px;
- text-align: justify;
- vertical-align:top;
- }
- td.formLeft
- {
- padding: 6px;
- text-align: left;
- vertical-align: top;
- }
- td.data1
- {
- background-color: #eee;
- vertical-align: top;
- padding-left: .3em;
- text-align: left;
- }
- td.data2
- {
- background-color: #ddd;
- vertical-align: top;
- padding-left: .3em;
- text-align: left;
- }
- td.text
- {
- color: #000;
- font-family: verdana;
- font-size: 12px;
- }
- th
- {
- text-align: left;
- }
- th.header
- {
- border-bottom: #666 1px solid;
- vertical-align: bottom;
- }
-
- input,textarea,select
- {
- background-color: rgb(108,131,176);
- font-family: courier;
- font-size: 12px;
- background-color: #ccc;
- border: #000000 1px solid;
- color: #111111;
- }
-
- input.button
- {
- background-color: #fff;
- color: rgb(108,131,176);
- border: 1px dashed rgb(108,131,176);
- font-family: trebuchet ms, tahoma, verdana;
- font-size: 12px;
- }
+ body,table,td,img
+ {
+ border: 0px;
+ margin: 0px;
+ padding: 0px;
+ }
+
+/* Main Wrapper Data Format */
+ td.preHeader
+ {
+ background-color: #000;
+ border-bottom: 1px solid rgb( 69, 84, 113 );
+ height: 16px;
+ text-align: right;
+ }
+ td.headerFill
+ {
+ background-color: rgb( 108, 131, 176 );
+ border-bottom: 1px solid #000;
+ }
+ td.headerDisplay
+ {
+ background-color: rgb( 108, 131, 176 );
+ padding-left: 16px;
+ }
+ td.mainLinks
+ {
+ background-color: #eee;
+ border-bottom: 1px solid #000;
+ height: 22px;
+ padding-left: 12px;
+ }
+ td.sideBar
+ {
+ background-color: #fff;
+ text-align: center;
+ vertical-align: top;
+ width: 150px;
+ }
+ td.sideBarGrey
+ {
+ background-color: #eee;
+ border-bottom: 1px solid #000;
+ text-align: left;
+ vertical-align: top;
+ width: 150px;
+ }
+ td.sideBarSmall
+ {
+ background-color: rgb( 108, 131, 176 );
+ border-bottom: 1px solid #000;
+ height: 16px;
+ text-align: right;
+ width: 150px;
+ }
+ td.sideBarSmallHeader
+ {
+ background-color: rgb(108,131,176);
+ vertical-align: top;
+ height: 16px;
+ padding-top: 1px;
+ padding-bottom: 2px;
+ text-align: right;
+ width: 150px;
+ }
+ td.subLinks
+ {
+ background-color: rgb( 225, 228, 232 );
+ border-right: 1px solid #000;
+ color: rgb( 120, 120, 120 );
+ padding-left: 12px;
+ height: 19px;
+ }
+ td.contentDisplay
+ {
+ background-color: #ffffff;
+ border-right: 1px solid #000;
+ border-left: 1px solid #000;
+ border-bottom: 1px solid #000;
+ text-align: center;
+ vertical-align: top;
+ padding: 10;
+ }
+
+ td.footerDisplay
+ {
+ background-color: #eee;
+ border-bottom: 1px solid #000;
+ text-align: center;
+ }
+
+/* Containers Used Globally */
+ table.boxSoft
+ {
+ width: 90%;
+ background-color: #ddd;
+ text-align: left;
+ }
+ td.boxSoft
+ {
+ background-color: #fff;
+ padding: 10;
+ text-align: left;
+ }
+ td.boxSoftColumn
+ {
+ padding-left: 16;
+ padding-right: 16;
+ text-align: justify;
+ vertical-align: top;
+ text-indent: 20px;
+ }
+ td.div
+ {
+ background-color: #eee;
+ width: 3px;
+ }
+ td.boxSoftTitle
+ {
+ border-bottom: 1px solid #fff;
+ border-top: 1px solid #fff;
+ background-color: rgb( 241, 242, 244 );
+ padding-left: 10;
+ padding-top: 1;
+ padding-bottom: 1;
+ text-align: left;
+ }
+ table.boxSoftSmall
+ {
+ width: 94%;
+ background-color: #ddd;
+ }
+ td.boxSoftSmall
+ {
+ background-color: #fff;
+ text-align: center;
+ padding-top: 2;
+ padding-bottom: 2;
+ }
+ td.boxSoftSmallTitle
+ {
+ border-bottom: 1px solid #ccc;
+ background-color: rgb( 241, 242, 244 );
+ padding-left: 10;
+ }
+ td.ss /* ss = small space */
+ {
+ padding-left: 6px;
+ vertical-align: top;
+ }
+ td.display
+ {
+ border-bottom: 1px solid #000;
+ padding-bottom: 6px;
+ }
+ td.features
+ {
+ padding: 4px;
+ text-align: justify;
+ vertical-align:top;
+ }
+ td.formLeft
+ {
+ padding: 6px;
+ text-align: left;
+ vertical-align: top;
+ }
+ td.data1
+ {
+ background-color: #eee;
+ vertical-align: top;
+ padding-left: .3em;
+ text-align: left;
+ }
+ td.data2
+ {
+ background-color: #ddd;
+ vertical-align: top;
+ padding-left: .3em;
+ text-align: left;
+ }
+ td.text
+ {
+ color: #000;
+ font-size: 12px;
+ }
+ th
+ {
+ text-align: left;
+ }
+ th.header
+ {
+ border-bottom: #666 1px solid;
+ vertical-align: bottom;
+ }
+
+ input,textarea,select
+ {
+ background-color: rgb(108,131,176);
+ font-family: monospace;
+ font-size: 12px;
+ background-color: #ccc;
+ border: #000000 1px solid;
+ color: #111111;
+ }
+
+ input.button
+ {
+ background-color: #fff;
+ color: rgb(108,131,176);
+ border: 1px solid rgb(108,131,176);
+ font-size: 12px;
+ }
+
diff --git a/web/html/css/fonts.css b/web/html/css/fonts.css
index 8a60e05..fdeddbe 100644
--- a/web/html/css/fonts.css
+++ b/web/html/css/fonts.css
@@ -2,11 +2,10 @@
span /* Applicable by default in all fonts */
{
color: #666;
- font-family: verdana, trebuchet ms, tahoma, luxi sans;
+ font-family: Bitstream Vera Sans, Lucida Grande, Arial, sans-serif;
}
span.f1 /* Important */
{
- font-family: verdana;
font-size: 20px;
letter-spacing: 1px;
}
@@ -25,13 +24,11 @@
span.f4 /* Content Text */
{
color: #444;
- font-family: verdana;
font-size: 12px;
}
span.f5 /* Content Small */
{
color: #333;
- font-family: trebuchet ms, tahoma, verdana;
font-size: 11px;
}
span.f6 /* Red Message */
@@ -55,13 +52,11 @@
span.error /* Content Text */
{
color: #900;
- font-family: verdana;
font-size: 12px;
}
span.warning /* Content Text */
{
color: #C0C000;
- font-family: verdana;
font-size: 12px;
}
@@ -95,7 +90,6 @@
color: rgb( 201, 209, 226 );
font-weight: bold;
font-size: 11px;
- font-family: tahoma, trebuchet ms, verdana;
padding-right: 8px;
word-spacing: 8px;
}
@@ -104,7 +98,6 @@
color: #fff;
font-weight: bold;
font-size: 11px;
- font-family: tahoma, trebuchet ms, verdana;
padding-right: 8px;
}
diff --git a/web/html/hacker.php b/web/html/hacker.php
index ef54bb6..d288a5e 100644
--- a/web/html/hacker.php
+++ b/web/html/hacker.php
@@ -12,6 +12,6 @@ print "<p>\n";
print __("If this problem persists, please contact the site administrator.");
print "</p>\n";
-html_footer("\$Id$");
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/images/logo.png b/web/html/images/logo.png
new file mode 100644
index 0000000..b2b6d86
--- /dev/null
+++ b/web/html/images/logo.png
Binary files differ
diff --git a/web/html/images/tab.png b/web/html/images/tab.png
new file mode 100644
index 0000000..56d2e61
--- /dev/null
+++ b/web/html/images/tab.png
Binary files differ
diff --git a/web/html/images/title.png b/web/html/images/title.png
new file mode 100644
index 0000000..e16971a
--- /dev/null
+++ b/web/html/images/title.png
Binary files differ
diff --git a/web/html/images/title_back.png b/web/html/images/title_back.png
new file mode 100644
index 0000000..95c98d7
--- /dev/null
+++ b/web/html/images/title_back.png
Binary files differ
diff --git a/web/html/index.php b/web/html/index.php
index d175797..b379d4d 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -79,19 +79,19 @@ if (isset($_REQUEST["user"]) || isset($_REQUEST["pass"])) {
html_header();
# Big Top Level Table (Table 1)
-print "<table border='0' cellpadding='0' cellspacing='3' width='90%'>\n";
-print "<tr>\n";
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">AUR ".__("Home")."</span></div>\n";
+echo " <div class=\"frontpgboxbody\">\n";
+echo "<table border='0' cellpadding='0' cellspacing='3' width='90%'>\n";
+echo "<tr>\n";
# MAIN: Top Left
print "<td class='boxSoft' valign='top'>";
print "<p>".__("Welcome to the AUR! Please read the %hAUR User Guidelines%h and %hAUR TU Guidelines%h for more information.", array('<a href="http://wiki.archlinux.org/index.php/AUR_User_Guidelines">', '</a>', '<a href="http://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">', '</a>'))."<br>";
print __("Contributed PKGBUILDs <b>must</b> conform to the %hArch Packaging Standards%h otherwise they will be deleted!", array('<a href="http://wiki.archlinux.org/index.php/Arch_Packaging_Standards">', '</a>'))."</p>";
-#print "<p>".__("If you have feedback about the AUR, please leave it in %hFlyspray%h.", array('<a href="http://bugs.archlinux.org/index.php?tasks=all&amp;project=2">', '</a>'))."<br>";
-#print __("Email discussion about the AUR takes place on the %sTUR Users List%s.", array('<a href="http://www.archlinux.org/mailman/listinfo/tur-users">', '</a>'))."</p>";
print "<p>".__("Remember to vote for your favourite packages!")."<br>";
print __("The most popular packages will be provided as binary packages in [community].")."</p>";
-#print "<p>".__("Though we can't vouch for their contents, we provide a %hlist of user repositories%h for your convenience.", array('<a href="http://wiki2.archlinux.org/index.php/Unofficial%20Repositories">', '</a>'))."</p>";
# MAIN: Top Right
print "</td>";
@@ -178,9 +178,6 @@ print "</tr>";
print "</table>";
# End Table 2
-#print " <td>&nbsp;&nbsp;</td>";
-#print " <td align='left' valign='top' nowrap>\n";
-
# MAIN: Bottom Right
print "</td>";
print "<td class='boxSoft' valign='top'>";
@@ -357,8 +354,10 @@ print "</table>";
print " </td>";
print "</tr>\n";
print "</table>\n";
+echo "</div>\n";
# End Table 1
-
-html_footer("<b>Version 1.3.1</b> \$Id$");
+echo " </div>";
+echo "</div>";
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/logout.php b/web/html/logout.php
index 76736b7..0b275b8 100644
--- a/web/html/logout.php
+++ b/web/html/logout.php
@@ -19,10 +19,9 @@ if (isset($_COOKIE["AURSID"])) {
setcookie("AURLANG", "", time() - (60*60*24*30), "/");
}
-html_header(); # print out the HTML header
-print __("You have been successfully logged out.")."<br />\n";
+header('Location: index.php');
+exit;
-
-html_footer("\$Id$");
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/packages.php b/web/html/packages.php
index 4cb8c47..2ae3bf0 100644
--- a/web/html/packages.php
+++ b/web/html/packages.php
@@ -66,6 +66,27 @@ if (isset($_REQUEST["do_Flag"])) {
print "<p>\n";
print __("The selected packages have been flagged out-of-date.");
print "</p>\n";
+
+ # notification by tardo.
+ $f_name = username_from_sid($_COOKIE['AURSID']);
+ $f_email = email_from_sid($_COOKIE['AURSID']);
+ $f_uid = uid_from_sid($_COOKIE['AURSID']);
+ $q = "SELECT Packages.Name, Users.Email, Packages.ID ";
+ $q.= "FROM Packages, Users ";
+ $q.= "WHERE Packages.ID IN (" . $flag .") ";
+ $q.= "AND Users.ID = Packages.MaintainerUID ";
+ $q.= "AND Users.ID != " . $f_uid;
+ $result = db_query($q, $dbh);
+ if (mysql_num_rows($result)) {
+ while ($row = mysql_fetch_assoc($result)) {
+ # construct email
+ $body = "Your package " . $row['Name'] . " has been flagged out of date by " . $f_name . ". You may view your package at:\nhttp://aur.archlinux.org/packages.php?do_Details=1&ID=" . $row['ID'];
+ $body = wordwrap($body, 70);
+ $headers = "To: ".$row['Email']."\nReply-to: nobody@archlinux.org\nFrom:aur-notify@archlinux.org\nX-Mailer: PHP\nX-MimeOLE: Produced By AUR\n";
+ @mail(' ', "AUR Out-of-date Notification for ".$row['Name'], $body, $headers);
+ }
+ }
+
} else {
print "<p>\n";
print __("You did not select any packages to flag.");
@@ -579,6 +600,6 @@ if (isset($_REQUEST["do_Flag"])) {
}
-html_footer("\$Id$");
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/pkgedit.php b/web/html/pkgedit.php
index e617b75..c1169f4 100644
--- a/web/html/pkgedit.php
+++ b/web/html/pkgedit.php
@@ -27,7 +27,7 @@ if (isset($_COOKIE["AURSID"])) {
if (!$atype) {
print __("You must be logged in before you can edit package information.");
print "<br />\n";
- html_footer($svn_idstr);
+ html_footer(AUR_VERSION);
exit();
}
@@ -36,7 +36,7 @@ if (!$atype) {
if (!$_REQUEST["ID"]) {
print __("Missing package ID.");
print "<br />\n";
- html_footer($svn_idstr);
+ html_footer(AUR_VERSION);
}
@@ -59,7 +59,7 @@ if ($_REQUEST["del_Comment"]) {
print __("Missing comment ID.")."<br />\n";
}
pkgdetails_link($_REQUEST["ID"]);
- html_footer($svn_idstr);
+ html_footer(AUR_VERSION);
exit();
}
@@ -120,7 +120,7 @@ if ($_REQUEST["add_Comment"]) {
print "<input type='reset' value=\"".__("Reset")."\">\n";
print "</form>\n";
}
- html_footer($svn_idstr);
+ html_footer(AUR_VERSION);
exit();
}
@@ -171,13 +171,13 @@ if ($_REQUEST["change_Category"]) {
print "</form>\n";
}
- html_footer($svn_idstr);
+ html_footer(AUR_VERSION);
exit();
}
print __("You've found a bug if you see this....")."<br />\n";
-html_footer($svn_idstr); # Use the $Id$ keyword
+html_footer(AUR_VERSION); # Use the $Id$ keyword
# NOTE: when checking in a new file, use
# 'svn propset svn:keywords "Id" filename.php'
# to tell svn to expand the "Id" keyword.
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 89ecfa4..6e754bf 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -9,7 +9,9 @@ include("config.inc"); # configuration file with dir locations
set_lang(); # this sets up the visitor's language
check_sid(); # see if they're still logged in
html_header(); # print out the HTML header
-print "<center>\n";
+echo "<div class=\"pgbox\">\n";
+echo " <div class=\"pgboxtitle\"><span class=\"f3\">".__("Submit")."</span></div>\n";
+echo " <div class=\"pgboxbody\">\n";
# Debugging
$DBUG = 0;
@@ -88,15 +90,15 @@ if ($_COOKIE["AURSID"]) {
# the uploaded package file.
#
- $upload_file = $UPLOAD_DIR . $_FILES["pfile"]["name"];
+ $upload_file = UPLOAD_DIR . $_FILES["pfile"]["name"];
if (move_uploaded_file($_FILES["pfile"]["tmp_name"], $upload_file)) {
# ok, we can proceed
#
- if (file_exists($INCOMING_DIR . $pkg_name)) {
+ if (file_exists(INCOMING_DIR . $pkg_name)) {
# blow away the existing file/dir and contents
#
- rm_rf($INCOMING_DIR . $pkg_name);
+ rm_rf(INCOMING_DIR . $pkg_name);
}
} else {
@@ -111,13 +113,13 @@ if ($_COOKIE["AURSID"]) {
#
if (!$error) {
- if (!@mkdir($INCOMING_DIR.$pkg_name)) {
+ if (!@mkdir(INCOMING_DIR.$pkg_name)) {
$error = __("Could not create incoming directory: %s.",
- array($INCOMING_DIR.$pkg_name));
+ array(INCOMING_DIR.$pkg_name));
} else {
- if (!@chdir($INCOMING_DIR.$pkg_name)) {
+ if (!@chdir(INCOMING_DIR.$pkg_name)) {
$error = __("Could not change directory to %s.",
- array($INCOMING_DIR.$pkg_name));
+ array(INCOMING_DIR.$pkg_name));
} else {
# try .gz first
#
@@ -135,40 +137,40 @@ if ($_COOKIE["AURSID"]) {
}
# At this point, if no error exists, the package has been extracted
- # There should be a $INCOMING_DIR.$pkg_name."/".$pkg_name directory
+ # There should be a INCOMING_DIR.$pkg_name."/".$pkg_name directory
# if the user packaged it correctly. However, if the file was
# packaged without the $pkg_name subdirectory, try and create it
# and move the package contents into the new sub-directory.
#
if (!$error) {
- if (is_dir($INCOMING_DIR.$pkg_name."/".$pkg_name) &&
- is_file($INCOMING_DIR.$pkg_name."/".$pkg_name."/PKGBUILD")) {
+ if (is_dir(INCOMING_DIR.$pkg_name."/".$pkg_name) &&
+ is_file(INCOMING_DIR.$pkg_name."/".$pkg_name."/PKGBUILD")) {
# the files were packaged correctly
#
- if (!@chdir($INCOMING_DIR.$pkg_name."/".$pkg_name)) {
+ if (!@chdir(INCOMING_DIR.$pkg_name."/".$pkg_name)) {
$error = __("Could not change to directory %s.",
- array($INCOMING_DIR.$pkg_name."/".$pkg_name));
+ array(INCOMING_DIR.$pkg_name."/".$pkg_name));
}
- $pkg_dir = $INCOMING_DIR.$pkg_name."/".$pkg_name;
- } elseif (is_file($INCOMING_DIR.$pkg_name."/PKGBUILD")) {
+ $pkg_dir = INCOMING_DIR.$pkg_name."/".$pkg_name;
+ } elseif (is_file(INCOMING_DIR.$pkg_name."/PKGBUILD")) {
# not packaged correctly, but recovery may be possible.
- # try and create $INCOMING_DIR.$pkg_name."/".$pkg_name and
+ # try and create INCOMING_DIR.$pkg_name."/".$pkg_name and
# move package contents into the new dir
#
- if (!@mkdir($INCOMING_DIR.$pkg_name."/".$pkg_name)) {
+ if (!@mkdir(INCOMING_DIR.$pkg_name."/".$pkg_name)) {
$error = __("Could not create directory %s.",
- array($INCOMING_DIR.$pkg_name."/".$pkg_name));
+ array(INCOMING_DIR.$pkg_name."/".$pkg_name));
} else {
exec("/bin/sh -c 'mv * ".$pkg_name."'");
- if (!file_exists($INCOMING_DIR.$pkg_name."/".$pkg_name."/PKGBUILD")) {
+ if (!file_exists(INCOMING_DIR.$pkg_name."/".$pkg_name."/PKGBUILD")) {
$error = __("Error exec'ing the mv command.");
}
}
- if (!@chdir($INCOMING_DIR.$pkg_name."/".$pkg_name)) {
+ if (!@chdir(INCOMING_DIR.$pkg_name."/".$pkg_name)) {
$error = __("Could not change to directory %s.",
- array($INCOMING_DIR.$pkg_name."/".$pkg_name));
+ array(INCOMING_DIR.$pkg_name."/".$pkg_name));
}
- $pkg_dir = $INCOMING_DIR.$pkg_name."/".$pkg_name;
+ $pkg_dir = INCOMING_DIR.$pkg_name."/".$pkg_name;
} else {
# some wierd packaging/extraction error - baal
#
@@ -177,7 +179,7 @@ if ($_COOKIE["AURSID"]) {
}
$shcmd = "/bin/mv ".$upload_file." ";
- $shcmd.= escapeshellarg($INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"]);
+ $shcmd.= escapeshellarg(INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"]);
@exec($shcmd);
# if no error, get list of directory contents and process PKGBUILD
@@ -353,9 +355,9 @@ if ($_COOKIE["AURSID"]) {
# Re-tar the package for consistency's sake
#
if (!$error) {
- if (!@chdir($INCOMING_DIR.$pkg_name)) {
+ if (!@chdir(INCOMING_DIR.$pkg_name)) {
$error = __("Could not change directory to %s.",
- array($INCOMING_DIR.$pkg_name));
+ array(INCOMING_DIR.$pkg_name));
}
}
if (!$error) {
@@ -415,9 +417,9 @@ if ($_COOKIE["AURSID"]) {
} else {
$q.="Safe=0, ";
}
- $fspath=$INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
+ $fspath=INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.="FSPath='".mysql_real_escape_string($fspath)."', ";
- $urlpath=$URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
+ $urlpath=URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.="URLPath='".mysql_real_escape_string($urlpath)."' ";
$q.="WHERE ID = " . $pdata["ID"];
$result = db_query($q, $dbh);
@@ -428,8 +430,8 @@ if ($_COOKIE["AURSID"]) {
$q = "INSERT INTO PackageContents ";
$q.= "(PackageID, FSPath, URLPath, FileSize) VALUES (";
$q.= $pdata['ID'].", ";
- $q.= "'".$INCOMING_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
- $q.= "'".$URL_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
+ $q.= "'".INCOMING_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
+ $q.= "'".URL_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
$q.= $v.")";
db_query($q);
}
@@ -498,9 +500,9 @@ if ($_COOKIE["AURSID"]) {
$q.= "UNIX_TIMESTAMP(), ";
$q.= uid_from_sid($_COOKIE["AURSID"]).", ";
$q.= uid_from_sid($_COOKIE["AURSID"]).", '";
- $fspath=$INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
+ $fspath=INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.= mysql_real_escape_string($fspath)."', '";
- $urlpath=$URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
+ $urlpath=URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.= mysql_real_escape_string($urlpath)."')";
$result = db_query($q, $dbh);
# print $result . "<br>";
@@ -513,8 +515,8 @@ if ($_COOKIE["AURSID"]) {
$q = "INSERT INTO PackageContents ";
$q.= "(PackageID, FSPath, URLPath, FileSize) VALUES (";
$q.= $packageID.", ";
- $q.= "'".$INCOMING_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
- $q.= "'".$URL_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
+ $q.= "'".INCOMING_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
+ $q.= "'".URL_DIR.$pkg_name."/".$pkg_name."/".$k."', ";
$q.= $v.")";
db_query($q);
}
@@ -665,8 +667,8 @@ if ($_COOKIE["AURSID"]) {
print __("You must create an account before you can upload packages.");
print "<br />\n";
}
-
-print "</center>\n";
-html_footer("\$Id$");
+echo " </div>\n";
+echo "</div>\n";
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/template.php b/web/html/template.php
index 175ba0b..6a158de 100644
--- a/web/html/template.php
+++ b/web/html/template.php
@@ -15,7 +15,7 @@ html_header(); # print out the HTML header
print __("Hi, this is worth reading!")."<br />\n";
-html_footer("\$Id$"); # Use the $Id$ keyword
+html_footer(AUR_VERSION); # Use the $Id$ keyword
# NOTE: when checking in a new file, use
# 'svn propset svn:keywords "Id" filename.php'
# to tell svn to expand the "Id" keyword.
diff --git a/web/html/timeout.php b/web/html/timeout.php
index 94a8637..96a3e2e 100644
--- a/web/html/timeout.php
+++ b/web/html/timeout.php
@@ -12,6 +12,6 @@ print "<p>\n";
print __("Click on the Home link above to log in.");
print "</p>\n";
-html_footer("\$Id$");
+html_footer(AUR_VERSION);
# vim: ts=2 sw=2 noet ft=php
?>
diff --git a/web/html/xml/README.txt b/web/html/xml/README.txt
new file mode 100644
index 0000000..fb37d7a
--- /dev/null
+++ b/web/html/xml/README.txt
@@ -0,0 +1,2 @@
+This is where the server will create the RSS feed file.
+This directory should be writeable by the the webserver.