summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/Makefile12
-rw-r--r--documentation/asciidoc.conf72
-rw-r--r--documentation/readme.txt103
3 files changed, 187 insertions, 0 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
new file mode 100644
index 0000000..10ca90b
--- /dev/null
+++ b/documentation/Makefile
@@ -0,0 +1,12 @@
+ASCIIDOC_OPTS = \
+ -f asciidoc.conf
+
+HTML_SOURCES = readme
+HTML_PAGES = readme.html
+
+%.html: %.txt asciidoc.conf
+ asciidoc $(ASCIIDOC_OPTS) --out-file=./$@ $*.txt
+
+all: $(HTML_PAGES)
+
+.PHONY: all
diff --git a/documentation/asciidoc.conf b/documentation/asciidoc.conf
new file mode 100644
index 0000000..e2e7267
--- /dev/null
+++ b/documentation/asciidoc.conf
@@ -0,0 +1,72 @@
+## linkman: macro
+# Inspired by/borrowed from the GIT source tree at Documentation/asciidoc.conf
+#
+# Usage: linkman:command[manpage-section]
+#
+# Note, {0} is the manpage section, while {target} is the command.
+#
+# Show man link as: <command>(<section>); if section is defined, else just show
+# the command.
+
+[macros]
+(?su)[\\]?(?P<name>linkman):(?P<target>\S*?)\[(?P<attrlist>.*?)\]=
+
+[attributes]
+asterisk=&#42;
+plus=&#43;
+caret=&#94;
+startsb=&#91;
+endsb=&#93;
+backslash=&#92;
+tilde=&#126;
+apostrophe=&#39;
+backtick=&#96;
+litdd=&#45;&#45;
+
+ifdef::backend-docbook[]
+[linkman-inlinemacro]
+{0%{target}}
+{0#<citerefentry>}
+{0#<refentrytitle>{target}</refentrytitle><manvolnum>{0}</manvolnum>}
+{0#</citerefentry>}
+endif::backend-docbook[]
+
+ifdef::backend-docbook[]
+ifndef::docbook-xsl-172[]
+# "unbreak" docbook-xsl v1.68 for manpages. v1.69 works with or without this.
+# v1.72 breaks with this because it replaces dots not in roff requests.
+[listingblock]
+<example><title>{title}</title>
+<literallayout>
+|
+</literallayout>
+{title#}</example>
+endif::docbook-xsl-172[]
+endif::backend-docbook[]
+
+ifdef::doctype-manpage[]
+ifdef::backend-docbook[]
+[header]
+template::[header-declarations]
+<refentry>
+<refentryinfo>
+<date>{pacman_date}</date>
+</refentryinfo>
+<refmeta>
+<refentrytitle>{mantitle}</refentrytitle>
+<manvolnum>{manvolnum}</manvolnum>
+<refmiscinfo class="source">Pacman</refmiscinfo>
+<refmiscinfo class="version">{pacman_version}</refmiscinfo>
+<refmiscinfo class="manual">Pacman Manual</refmiscinfo>
+</refmeta>
+<refnamediv>
+ <refname>{manname}</refname>
+ <refpurpose>{manpurpose}</refpurpose>
+</refnamediv>
+endif::backend-docbook[]
+endif::doctype-manpage[]
+
+ifdef::backend-xhtml11[]
+[linkman-inlinemacro]
+<a href="{target}.{0}.html">{target}{0?({0})}</a>
+endif::backend-xhtml11[]
diff --git a/documentation/readme.txt b/documentation/readme.txt
new file mode 100644
index 0000000..b6c6d31
--- /dev/null
+++ b/documentation/readme.txt
@@ -0,0 +1,103 @@
+aurweb
+======
+
+
+Name
+----
+aurweb - Arch User Repository
+
+
+Description
+-----------
+
+aurweb is a framework for hosting the Arch User Repository (AUR), a collection
+of packaging scripts that are created and submitted by the Arch Linux
+community. The scripts contained in the repository (PKGBUILDs) con be built
+using makepkg and installed via the Arch Linux package manager 'pacman'. The
+aurweb project aims to provide the necessary web interface, database schema,
+and scripts for a multi-lingual community-driven repository.
+
+
+Functionality
+-------------
+
+* Users may submit PKGBUILDs by pushing a git repository containing the
+ PKGBUILD and a .SRCINFO file to the AUR.
+* User accounts with varying permission levels (User, Trusted User, Developer).
+* Ability to search for specific submitted packages.
+* Display package information by parsing meta-data provided with the packages.
+* Users can make comments on package information pages.
+* Users can mark packages as out-of-date.
+* Vote for well-done and popular user submitted packages.
+* Trusted Users and Developers can search for and modify accounts.
+* Area for Trusted Users to post AUR-related proposals and vote on them.
+
+
+Directory Layout
+----------------
+
+po::
+ Translation files for strings in the aurweb interface.
+
+scripts::
+ Scripts for AUR maintenance.
+
+support::
+ Schema for the SQL database. Script for dummy data generation.
+
+web::
+ Web interface for the AUR
+
+git-integration::
+ Git interface for the AUR
+
+
+Links
+-----
+
+* The repository is hosted at git://projects.archlinux.org/aurweb.git -- see
+ HACKING for information on submitting patches.
+
+* Discovered bugs can be submitted to the aurweb bug tracker:
+ <https://bugs.archlinux.org/index.php?project=2>
+
+* Questions, comments, and patches related to aurweb can be sent to the AUR
+ development mailing list: mailto:aur-dev@archlinux.org -- mailing list
+ archives: <https://mailman.archlinux.org/mailman/listinfo/aur-dev>
+
+
+Bugs
+----
+Bugs? You must be kidding; there are no bugs in this software. But if we
+happen to be wrong, send us an email with as much detail as possible to
+mailto:aur-dev@archlinux.org.
+
+
+Maintainers
+-----------
+
+* Lukas Fleischer <lfleischer@archlinux.org>
+* Johannes Löthberg <johannes@kyriasis.com>
+
+
+Past Maintainers
+----------------
+
+* canyonknight <canyonknight@gmail.com> '(2013-2014)'
+* Loui Chang <louipc.ist@gmail.com> '(2008-2011)'
+* Callan Barrett <wizzomafizzo@gmail.com> '(2008-2009)'
+* eliott <eliott@cactuswax.net> '(2007-2009)'
+* Paul Mattal <paul@mattal.com> '(2007)'
+* Simo Leone <simo@archlinux.org> '(2005-2008)'
+* Eric Johnson '(2004-2005)'
+
+
+Contributors
+------------
+
+For a list of contributors, use +git shortlog -s+ on the aurweb.git repository.
+
+
+/////
+vim:set ts=4 sw=4 syntax=asciidoc noet spell spelllang=en_us:
+/////