summaryrefslogtreecommitdiffstats
path: root/web/template/pkgbase_details.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-04-05 02:06:54 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-04-05 12:21:36 +0200
commitf7d13b5b368f1432b9a1eb1798f94a70b9dc03b7 (patch)
tree5f6c1980ce15a5ddacba66bd80cbac9f5d6d4e24 /web/template/pkgbase_details.php
parentfb81bfd8dff66073de6704c1880fb921e58ef137 (diff)
downloadaurweb-f7d13b5b368f1432b9a1eb1798f94a70b9dc03b7.tar.xz
Add package base detail pages
This adds package base details pages, similar to the package details pages. Each package base details page contains general information (package base name, category, submitter, maintainer, ...) and links to all the corresponding packages. As on the package details pages, comments and links to several package actions are also provided. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/template/pkgbase_details.php')
-rw-r--r--web/template/pkgbase_details.php210
1 files changed, 210 insertions, 0 deletions
diff --git a/web/template/pkgbase_details.php b/web/template/pkgbase_details.php
new file mode 100644
index 0000000..a77ecd3
--- /dev/null
+++ b/web/template/pkgbase_details.php
@@ -0,0 +1,210 @@
+<?php
+$atype = account_from_sid($SID);
+$uid = uid_from_sid($SID);
+
+$base_id = intval($row['ID']);
+
+$catarr = pkgCategories();
+
+$submitter = username_from_id($row["SubmitterUID"]);
+$maintainer = username_from_id($row["MaintainerUID"]);
+
+$votes = $row['NumVotes'];
+
+# In case of wanting to put a custom message
+$msg = __('unknown');
+
+# Print the timestamps for last updates
+$updated_time = ($row["ModifiedTS"] == 0) ? $msg : gmdate("Y-m-d H:i", intval($row["ModifiedTS"]));
+$submitted_time = ($row["SubmittedTS"] == 0) ? $msg : gmdate("Y-m-d H:i", intval($row["SubmittedTS"]));
+$out_of_date_time = ($row["OutOfDateTS"] == 0) ? $msg : gmdate("Y-m-d", intval($row["OutOfDateTS"]));
+
+$urlpath = URL_DIR . substr($row['Name'], 0, 2) . "/" . $row['Name'];
+
+$pkgs = pkgbase_get_pkgnames($base_id);
+?>
+<div id="pkgdetails" class="box">
+ <h2><?= __('Package Base Details') . ': ' . htmlspecialchars($row['Name']) ?></h2>
+ <div id="detailslinks" class="listing">
+ <div id="actionlist">
+ <h4><?= __('Package Actions') ?></h4>
+ <ul class="small">
+ <li><a href="<?= $urlpath ?>/PKGBUILD"><?= __('View PKGBUILD') ?></a></li>
+ <li><a href="<?= $urlpath . '/' . $pkgs[0] ?>.tar.gz"><?= __('Download tarball') ?></a></li>
+ <li><span class="flagged"><?php if ($row["OutOfDateTS"] !== NULL) { echo __('Flagged out-of-date')." (${out_of_date_time})"; } ?></span></li>
+ <?php if ($USE_VIRTUAL_URLS && $uid): ?>
+ <?php if ($row["OutOfDateTS"] === NULL): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'flag/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_Flag" value="<?= __('Flag package out-of-date') ?>" />
+ </form>
+ </li>
+ <?php elseif (($row["OutOfDateTS"] !== NULL) &&
+ ($uid == $row["MaintainerUID"] || $atype == "Trusted User" || $atype == "Developer")): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'unflag/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_UnFlag" value="<?= __('Unflag package') ?>" />
+ </form>
+ </li>
+ <?php endif; ?>
+ <?php if (user_voted($uid, $row['ID'])): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'unvote/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_UnVote" value="<?= __('Remove vote') ?>" />
+ </form>
+ </li>
+ <?php else: ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'vote/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_Vote" value="<?= __('Vote for this package') ?>" />
+ </form>
+ </li>
+ <?php endif; ?>
+ <?php if (user_notify($uid, $row['ID'])): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'unnotify/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_UnNotify" value="<?= __('Disable notifications') ?>" />
+ </form>
+ </li>
+ <?php else: ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'notify/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_Notify" value="<?= __('Notify of new comments') ?>" />
+ </form>
+ </li>
+ <?php endif; ?>
+ <?php if ($atype == "Trusted User" || $atype == "Developer"): ?>
+ <li><a href="<?= get_pkg_uri($pkgs[0]) . 'delete/'; ?>"><?= __('Delete Package'); ?></a></li>
+ <li><a href="<?= get_pkg_uri($pkgs[0]) . 'merge/'; ?>"><?= __('Merge Package'); ?></a></li>
+ <?php endif; ?>
+ <?php endif; ?>
+
+ <?php if ($uid && $row["MaintainerUID"] === NULL): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'adopt/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_Adopt" value="<?= __('Adopt Package') ?>" />
+ </form>
+ </li>
+ <?php elseif ($uid && $uid == $row["MaintainerUID"] ||
+ $atype == "Trusted User" || $atype == "Developer"): ?>
+ <li>
+ <form action="<?= get_pkg_uri($pkgs[0]) . 'disown/'; ?>" method="post">
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <input type="submit" class="button text-button" name="do_Disown" value="<?= __('Disown Package') ?>" />
+ </form>
+ </li>
+ <?php endif; ?>
+ </ul>
+ </div>
+ </div>
+
+ <table id="pkginfo">
+ <tr>
+ <th><?= __('Category') . ': ' ?></th>
+<?php
+if ($SID && ($uid == $row["MaintainerUID"] ||
+ ($atype == "Developer" || $atype == "Trusted User"))):
+?>
+ <td>
+ <form method="post" action="<?= htmlspecialchars(get_pkg_uri($row['Name']), ENT_QUOTES); ?>">
+ <div>
+ <input type="hidden" name="action" value="do_ChangeCategory" />
+ <?php if ($SID): ?>
+ <input type="hidden" name="token" value="<?= htmlspecialchars($_COOKIE['AURSID']) ?>" />
+ <?php endif; ?>
+ <select name="category_id">
+<?php
+ foreach ($catarr as $cid => $catname):
+?>
+ <option value="<?= $cid ?>"<?php if ($cid == $row["CategoryID"]) { ?> selected="selected" <?php } ?>><?= $catname ?></option>
+ <?php endforeach; ?>
+ </select>
+ <input type="submit" value="<?= __('Change category') ?>"/>
+ </div>
+ </form>
+<?php else: ?>
+ <td>
+ <a href="<?= get_uri('/packages/'); ?>?C=<?= $row['CategoryID'] ?>"><?= $row['Category'] ?></a>
+<?php endif; ?>
+ </td>
+ </tr>
+ <tr>
+ <th><?= __('Submitter') .': ' ?></th>
+<?php
+if ($row["SubmitterUID"]):
+ if ($SID):
+ if (!$USE_VIRTUAL_URLS):
+?>
+ <td><a href="<?= get_uri('/account/'); ?>?Action=AccountInfo&amp;ID=<?= htmlspecialchars($row['SubmitterUID'], ENT_QUOTES) ?>" title="<?= __('View account information for')?> <?= htmlspecialchars($submitter) ?>"><?= htmlspecialchars($submitter) ?></a></td>
+ <?php else: ?>
+ <td><a href="<?= get_uri('/account/') . htmlspecialchars($submitter, ENT_QUOTES) ?>" title="<?= __('View account information for %s', htmlspecialchars($submitter)) ?>"><?= htmlspecialchars($submitter) ?></a></td>
+ <?php endif; ?>
+<?php else: ?>
+ <td><?= htmlspecialchars($submitter) ?></td>
+ <?php endif; ?>
+<?php else: ?>
+ <td><?= __('None') ?></td>
+<?php endif; ?>
+ </tr>
+ <tr>
+ <th><?= __('Maintainer') .': ' ?></th>
+<?php
+if ($row["MaintainerUID"]):
+ if ($SID):
+ if (!$USE_VIRTUAL_URLS):
+?>
+ <td><a href="<?= get_uri('/account/'); ?>?Action=AccountInfo&amp;ID=<?= htmlspecialchars($row['MaintainerUID'], ENT_QUOTES) ?>" title="<?= __('View account information for')?> <?= htmlspecialchars($maintainer) ?>"><?= htmlspecialchars($maintainer) ?></a></td>
+ <?php else: ?>
+ <td><a href="<?= get_uri('/account/') . htmlspecialchars($maintainer, ENT_QUOTES) ?>" title="<?= __('View account information for %s', htmlspecialchars($maintainer)) ?>"><?= htmlspecialchars($maintainer) ?></a></td>
+ <?php endif; ?>
+ <?php else: ?>
+ <td><?= htmlspecialchars($maintainer) ?></td>
+ <?php endif; ?>
+<?php else: ?>
+ <td><?= __('None') ?></td>
+<?php endif; ?>
+ </tr>
+ <tr>
+ <th><?= __('Votes') . ': ' ?></th>
+<?php if ($atype == "Developer" || $atype == "Trusted User"): ?>
+<?php if ($USE_VIRTUAL_URLS): ?>
+ <td><a href="<?= get_pkg_uri($row['Name']); ?>voters/"><?= $votes ?></a></td>
+<?php else: ?>
+ <td><a href="<?= get_uri('/voters/'); ?>?N=<?= htmlspecialchars($row['Name'], ENT_QUOTES) ?>"><?= $votes ?></a></td>
+<?php endif; ?>
+<?php else: ?>
+ <td><?= $votes ?></td>
+<?php endif; ?>
+ </tr>
+ <tr>
+ <th><?= __('First Submitted') . ': ' ?></th>
+ <td><?= $submitted_time ?></td>
+ </tr>
+ <tr>
+ <th><?= __('Last Updated') . ': ' ?></th>
+ <td><?= $updated_time ?></td>
+ </tr>
+ </table>
+
+ <div id="metadata">
+ <div id="pkgs" class="listing">
+ <h3><?= __('Packages') . " (" . count($pkgs) . ")"?></h3>
+<?php if (count($pkgs) > 0): ?>
+ <ul>
+<?php
+ while (list($k, $pkg) = each($pkgs)):
+?>
+ <li><a href="<?= htmlspecialchars(get_pkg_uri($pkg), ENT_QUOTES); ?>" title="<?= __('View packages details for').' '. htmlspecialchars($pkg) ?>"><?= htmlspecialchars($pkg) ?></a></li>
+ <?php endwhile; ?>
+ </ul>
+<?php endif; ?>
+ </div>
+ </div>
+</div>