summaryrefslogtreecommitdiffstats
path: root/web/template/pkgbase_details.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2014-05-31 12:17:22 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2014-06-02 18:15:12 +0200
commit019014a3acb6e10af11140082dfc319bd9d44fb3 (patch)
tree220f38ce269d309aaf93f8b91104e29d47fb1997 /web/template/pkgbase_details.php
parentd909ffcb17b81c617466f4437b696adb9a8d5144 (diff)
downloadaurweb-019014a3acb6e10af11140082dfc319bd9d44fb3.tar.xz
Add a "Search wiki" link to package details
Implements FS#33153. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web/template/pkgbase_details.php')
-rw-r--r--web/template/pkgbase_details.php1
1 files changed, 1 insertions, 0 deletions
diff --git a/web/template/pkgbase_details.php b/web/template/pkgbase_details.php
index eab3a53..da9a962 100644
--- a/web/template/pkgbase_details.php
+++ b/web/template/pkgbase_details.php
@@ -32,6 +32,7 @@ $pkgs = pkgbase_get_pkgnames($base_id);
<ul class="small">
<li><a href="<?= $urlpath ?>/PKGBUILD"><?= __('View PKGBUILD') ?></a></li>
<li><a href="<?= $urlpath . '/' . $row['Name'] ?>.tar.gz"><?= __('Download tarball') ?></a></li>
+ <li><a href="https://wiki.archlinux.org/index.php/Special:Search?search=<?= urlencode($row['Name']) ?>"><?= __('Search wiki') ?></a></li>
<li><span class="flagged"><?php if ($row["OutOfDateTS"] !== NULL) { echo __('Flagged out-of-date')." (${out_of_date_time})"; } ?></span></li>
<?php if ($USE_VIRTUAL_URLS && $uid): ?>
<?php if ($row["OutOfDateTS"] === NULL): ?>