diff options
author | Lukas Fleischer <archlinux@cryptocrack.de> | 2010-11-04 18:10:56 +0100 |
---|---|---|
committer | Lukas Fleischer <archlinux@cryptocrack.de> | 2011-01-19 23:18:09 +0100 |
commit | ec0dfc27deb246ee7d7f19fd5290e499805869d2 (patch) | |
tree | 3f267383b82cc4ef34f3c3e51b10bb0795b948e6 /UPGRADING | |
parent | 233f67b87edf0d063c0f56cece50c2f1bb1a31ff (diff) | |
download | aurweb-ec0dfc27deb246ee7d7f19fd5290e499805869d2.tar.xz |
Removed code for tarball extraction.
Automatic tarball extraction was vulnerable in different ways. Users
should also only use source tarballs to build packages, so this has been
removed completely. From now on, only the PKGBUILD is extracted in a
secure manner.
Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'UPGRADING')
-rw-r--r-- | UPGRADING | 23 |
1 files changed, 23 insertions, 0 deletions
@@ -3,9 +3,32 @@ Upgrading From 1.7.0 to 1.8.0 ------------------- + +1. Run the following MySQL statements: + +---- ALTER TABLE Packages ADD OutOfDateTS BIGINT UNSIGNED NULL DEFAULT NULL; UPDATE Packages SET OutOfDateTS = UNIX_TIMESTAMP() WHERE OutOfDate = 1; ALTER TABLE Packages DROP OutOfDate; +---- + +2. You will need to update all packages which are stored in the incoming dir as +in 1.8.0, source tarballs are no longer extracted automatically and PKGBUILDs +are from now on located in the same subdirectories as the tarballs themselves. +The following script will do the conversion automatically when being run inside +"$INCOMING_DIR": + +---- +#!/bin/bash + +for pkg in *; do + if [ -d "${pkg}" -a ! -f "${pkg}/PKGBUILD" ]; then + pkgbuild_file=$(find -P "${pkg}" -name PKGBUILD) + [ -n "${pkgbuild_file}" ] && \ + cp "${pkgbuild_file}" "${pkg}/PKGBUILD" + fi +done +---- From 1.6.0 to 1.7.0 ------------------- |