diff options
author | Lukas Fleischer <archlinux@cryptocrack.de> | 2014-12-19 10:46:30 +0100 |
---|---|---|
committer | Lukas Fleischer <archlinux@cryptocrack.de> | 2014-12-19 10:49:04 +0100 |
commit | cee68a95f3a6e7a5c9c13cb07ba940db4a0ade85 (patch) | |
tree | b437d318c5dd0b8de4ebe11fdd72e68284f76c81 | |
parent | 2de66131b8aa8d77b8f7986517f3c25553c4f71a (diff) | |
download | aurweb-cee68a95f3a6e7a5c9c13cb07ba940db4a0ade85.tar.xz |
Suggest using makepkg instead of mkaurball
pacman 4.2.0 supports .SRCINFO and generates meta data by default.
Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
-rw-r--r-- | README | 8 | ||||
-rw-r--r-- | web/html/pkgsubmit.php | 4 |
2 files changed, 6 insertions, 6 deletions
@@ -3,10 +3,10 @@ Arch User Repository (AUR) The Arch User Repository (AUR) is a framework for hosting a collection of packaging scripts that are created and submitted by the Arch community. The -scripts contained in the repository (PKGBUILDs) can be built using the AUR -building/packaging script `mkaurball` and installed via the Arch package -manager `pacman`. The AUR project aims to provide the necessary web interface, -database schema, and scripts for a multi-lingual community-driven repository. +scripts contained in the repository (PKGBUILDs) can be built using makepkg and +installed via the Arch package manager pacman. The AUR project aims to provide +the necessary web interface, database schema, and scripts for a multi-lingual +community-driven repository. Functionality ------------- diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php index d8df290..098c3fa 100644 --- a/web/html/pkgsubmit.php +++ b/web/html/pkgsubmit.php @@ -124,7 +124,7 @@ if ($uid): if (empty($srcinfo_raw)) { $srcinfo_raw = ''; if (!$error) { - $error = __("The source package does not contain any meta data. Please use `mkaurball` to create AUR source packages."); + $error = __("The source package does not contain any meta data. Please use `makepkg --source` from pacman 4.2.0 or newer to create AUR source packages."); } } @@ -413,7 +413,7 @@ html_header("Submit"); <div class="box"> <h2><?= __("Submit"); ?></h2> - <p><?= __("Upload your source packages here. Create source packages with `mkaurball`.") ?></p> + <p><?= __("Upload your source packages here. Create source packages with `makepkg --source`.") ?></p> <?php if (empty($_REQUEST['pkgsubmit']) || $error): |