summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2015-06-30 20:08:30 +0200
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-30 20:08:30 +0200
commit5ce710a06aed583a5bffd0ed5956129f63bd31b0 (patch)
tree7c49f0a1ca78fad8d3a0e595576aa6bbbef6f048
parent7038cbd9d90e4f5b0d446fce0802b72d351a0a56 (diff)
downloadaurweb-5ce710a06aed583a5bffd0ed5956129f63bd31b0.tar.xz
docs: Add initial asciidocified hacking
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
-rw-r--r--documentation/Makefile4
-rw-r--r--documentation/hacking.txt64
2 files changed, 66 insertions, 2 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 10ca90b..7aa1483 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -1,8 +1,8 @@
ASCIIDOC_OPTS = \
-f asciidoc.conf
-HTML_SOURCES = readme
-HTML_PAGES = readme.html
+HTML_SOURCES = readme hacking
+HTML_PAGES = readme.html hacking.html
%.html: %.txt asciidoc.conf
asciidoc $(ASCIIDOC_OPTS) --out-file=./$@ $*.txt
diff --git a/documentation/hacking.txt b/documentation/hacking.txt
new file mode 100644
index 0000000..a927fe5
--- /dev/null
+++ b/documentation/hacking.txt
@@ -0,0 +1,64 @@
+Hacking
+=======
+
+
+*DISCLAIMER*: We realize the code doesn't necessarily follow all the rules.
+This is an attempt to establish a standard coding style for future development.
+
+
+Coding style guidelines
+-----------------------
+
+Column width: 79 columns or less, within reason.
+
+Indentation: tabs (standard eight column width)
+
+Please don't add any mode lines. Adjust your editor to display tabs to your
+preferred width. Generally code should work with the standard eight column
+tabs.
+
+No short open tags ('<?'). Do not end files with a close tag ('?>'). Try
+embedding as little XHTML in the PHP as possible. Consider creating templates
+for XHTML.
+
+All markup should conform to XHTML 1.0 Strict requirements. You can use
+<http://validator.w3.org> to check the markup.
+
+Prevent PHP Notices by using isset() or empty() in conditionals that reference
+$_GET, $_POST, or $_REQUEST variables.
+
+MySQL queries should generally go into functions.
+
+
+Submitting patches
+------------------
+
+!!! PLEASE TEST YOUR PATCHES BEFORE SUBMITTING !!!
+
+Submit uncompressed git-formatted patches to mailto:aur-dev@archlinux.org.
+
+You will need to register on the mailing list before submitting:
+<https://mailman.archlinux.org/mailman/listinfo/aur-dev>
+
+Base your patches on the master branch as forward development is done there.
+When writing patches please keep unnecessary changes to a minimum.
+
+Try to keep your commits small and focused. Smaller patches are much easier to
+review and have a better chance of being pushed more quickly into the main
+repo. Smaller commits also makes reviewing the commit history and tracking down
+specific changes much easier.
+
+Try to make your commit messages brief but descriptive.
+
+
+Glossary
+--------
+
+git-formatted patch::
+ A patch that is produced via `git format-patch` and is sent via `git
+ send-email` or as an in-line attachment of an email.
+
+
+/////
+vim:set ts=4 sw=4 syntax=asciidoc noet spell spelllang=en_us:
+/////